summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2014-01-19 10:30:20 +0000
committerMike Frysinger <vapier@gentoo.org>2014-01-19 10:30:20 +0000
commit91f36000048df6595b09792cbaa8cc432033011b (patch)
treebce1473651522819f2f9da462502d88f132eb117 /dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild
parentStable for ppc64, wrt bug #496632 (diff)
downloadhistorical-91f36000048df6595b09792cbaa8cc432033011b.tar.gz
historical-91f36000048df6595b09792cbaa8cc432033011b.tar.bz2
historical-91f36000048df6595b09792cbaa8cc432033011b.zip
Fix cross-compiling due to AC_TRY_RUN.
Package-Manager: portage-2.2.8/cvs/Linux x86_64 Manifest-Sign-Key: 0xD2E96200
Diffstat (limited to 'dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild')
-rw-r--r--dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild b/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild
index 46514b83b5b2..1dbf7262c5cb 100644
--- a/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild
+++ b/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild,v 1.2 2014/01/19 10:21:13 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs/cvs-1.12.13.1-r2.ebuild,v 1.3 2014/01/19 10:30:16 vapier Exp $
EAPI=3
-inherit eutils pam versionator
+inherit eutils pam toolchain-funcs versionator
DESCRIPTION="Concurrent Versions System - source code revision control tools"
HOMEPAGE="http://www.nongnu.org/cvs/"
@@ -70,6 +70,11 @@ src_configure() {
ewarn "The server and proxy code are enabled as they are required for tests."
myconf="--enable-server --enable-proxy"
fi
+ if tc-is-cross-compiler ; then
+ # Sane defaults when cross-compiling (as these tests want to
+ # try and execute code).
+ export cvs_cv_func_printf_ptr="yes"
+ fi
econf \
--with-external-zlib \
--with-tmpdir=/tmp \