summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-09-10 09:08:18 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-09-10 09:08:18 +0000
commit30336ac0850c8c1b82c08d1e339028e00437cbda (patch)
tree8a19df17af6a846d56c81d57f5d7386acb2370a2 /eclass/commonbox.eclass
parentCorrected syntax in ebuild; fixed sed lines (diff)
downloadhistorical-30336ac0850c8c1b82c08d1e339028e00437cbda.tar.gz
historical-30336ac0850c8c1b82c08d1e339028e00437cbda.tar.bz2
historical-30336ac0850c8c1b82c08d1e339028e00437cbda.zip
small fix0rs
Diffstat (limited to 'eclass/commonbox.eclass')
-rw-r--r--eclass/commonbox.eclass12
1 files changed, 7 insertions, 5 deletions
diff --git a/eclass/commonbox.eclass b/eclass/commonbox.eclass
index ff5700bce17b..e9a95cf1768f 100644
--- a/eclass/commonbox.eclass
+++ b/eclass/commonbox.eclass
@@ -1,7 +1,7 @@
# Copyright 2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2
# Author: Seemant Kulleen <seemant@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/eclass/commonbox.eclass,v 1.9 2002/09/05 04:34:53 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/commonbox.eclass,v 1.10 2002/09/10 09:08:18 seemant Exp $
# The commonbox eclass is designed to allow easier installation of the box
# window managers such as blackbox and fluxbox and commonbox
@@ -12,7 +12,7 @@
ECLASS=commonbox
INHERITED="$INHERITED $ECLASS"
-EXPORT_FUNCTIONS src_unpack src_compile src_install pkg_postinst
+EXPORT_FUNCTIONS src_compile src_install pkg_postinst
DEPEND="sys-apps/supersed
x11-misc/commonbox-utils
@@ -30,9 +30,7 @@ then
MYBIN="${PN}"
fi
-commonbox_src_unpack() {
-
- unpack ${A}
+commonprep() {
ssed -i 's:data ::' ${S}/Makefile.am
@@ -65,11 +63,15 @@ commonbox_src_unpack() {
commonbox_src_compile() {
+ commonprep
+
if [ -z "${BOOTSTRAP}" ]
then
aclocal
automake
autoconf
+ else
+ ./bootstrap
fi
use nls \