summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-10-29 09:54:50 +0000
committerMichał Górny <mgorny@gentoo.org>2012-10-29 09:54:50 +0000
commit05510643e9d35567d4c23bef754202ac0eeb01ac (patch)
tree73875ed68adf876211125a23a9bc0d69f0aaa412 /eclass/distutils-r1.eclass
parentFixing useflag madness (diff)
downloadhistorical-05510643e9d35567d4c23bef754202ac0eeb01ac.tar.gz
historical-05510643e9d35567d4c23bef754202ac0eeb01ac.tar.bz2
historical-05510643e9d35567d4c23bef754202ac0eeb01ac.zip
Remove redundant "cd ${BUILD_DIR}" calls.
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass4
1 files changed, 1 insertions, 3 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index ca455f99329b..ba936d17641d 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.11 2012/10/29 09:51:27 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.12 2012/10/29 09:54:50 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -153,7 +153,6 @@ distutils-r1_python_configure() {
distutils-r1_python_compile() {
debug-print-function ${FUNCNAME} "${@}"
- cd "${BUILD_DIR}" || die
set -- "${PYTHON}" setup.py build "${@}"
echo "${@}"
"${@}" || die
@@ -217,7 +216,6 @@ distutils-r1_python_install() {
unset PYTHONDONTWRITEBYTECODE
- cd "${BUILD_DIR}" || die
set -- "${PYTHON}" setup.py install "${flags[@]}" --root="${D}" "${@}"
echo "${@}"
"${@}" || die