summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-12-13 16:47:25 +0000
committerMichał Górny <mgorny@gentoo.org>2012-12-13 16:47:25 +0000
commit586d54a4c021a6e363a980f3d725bc4053c31b1d (patch)
treec54b5961e4e996c77b38485a24678250a8823743 /eclass/distutils-r1.eclass
parentsys-fs/cachefilesd: Build as PIE binary as suggested by upstream (diff)
downloadhistorical-586d54a4c021a6e363a980f3d725bc4053c31b1d.tar.gz
historical-586d54a4c021a6e363a980f3d725bc4053c31b1d.tar.bz2
historical-586d54a4c021a6e363a980f3d725bc4053c31b1d.zip
Add (temporary) fix for sandbox failures when compiling Python modules. Bug #447126.
Diffstat (limited to 'eclass/distutils-r1.eclass')
-rw-r--r--eclass/distutils-r1.eclass6
1 files changed, 5 insertions, 1 deletions
diff --git a/eclass/distutils-r1.eclass b/eclass/distutils-r1.eclass
index f5cc4e6f7f8e..4ac9f01377cf 100644
--- a/eclass/distutils-r1.eclass
+++ b/eclass/distutils-r1.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.31 2012/12/09 20:56:25 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/distutils-r1.eclass,v 1.32 2012/12/13 16:47:25 mgorny Exp $
# @ECLASS: distutils-r1
# @MAINTAINER:
@@ -323,6 +323,10 @@ distutils-r1_python_install() {
local PYTHONDONTWRITEBYTECODE
export PYTHONDONTWRITEBYTECODE
+ # python likes to compile any module it sees, which triggers sandbox
+ # failures if some packages haven't compiled their modules yet.
+ addpredict "$(python_get_sitedir)"
+
local root=${D}/_${EPYTHON}
esetup.py install "${flags[@]}" --root="${root}" "${@}"