summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2006-01-12 03:44:33 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2006-01-12 03:44:33 +0000
commitd16865cb01e7441773cbc60293c840460b6f7bf5 (patch)
tree5bb7379cd69d8b5f1a03735fca5b5924d2865169 /eclass/font-ebdftopcf.eclass
parentNew version, with a manpage and more useomments. (diff)
downloadhistorical-d16865cb01e7441773cbc60293c840460b6f7bf5.tar.gz
historical-d16865cb01e7441773cbc60293c840460b6f7bf5.tar.bz2
historical-d16865cb01e7441773cbc60293c840460b6f7bf5.zip
Minor cleanup for ebdftopcf and a default src_compile for simple ebuilds to use with font.eclass. See the example from the eclass manpage with the package.
Diffstat (limited to 'eclass/font-ebdftopcf.eclass')
-rw-r--r--eclass/font-ebdftopcf.eclass14
1 files changed, 12 insertions, 2 deletions
diff --git a/eclass/font-ebdftopcf.eclass b/eclass/font-ebdftopcf.eclass
index 6bd3ab46f537..8eb9fdd14261 100644
--- a/eclass/font-ebdftopcf.eclass
+++ b/eclass/font-ebdftopcf.eclass
@@ -1,11 +1,12 @@
# Copyright 2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/font-ebdftopcf.eclass,v 1.1 2006/01/12 01:52:17 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/font-ebdftopcf.eclass,v 1.2 2006/01/12 03:44:33 robbat2 Exp $
# Author: Robin H. Johnson <robbat2@gentoo.org>
# font-ebdftopcf.eclass
# Eclass to make PCF font generator from BDF uniform and optimal
+# The manpage for this eclass is in media-gfx/ebdftopcf.
# Variable declarations
DEPEND="media-gfx/ebdftopcf"
@@ -17,10 +18,19 @@ RDEPEND=""
ebdftopcf() {
local bdffiles
bdffiles="$@"
- [ -z "$bdffiles" ] && bdffiles="${BDFFILES}"
[ -z "$bdffiles" ] && die "No BDF files specified."
emake -f /usr/share/ebdftopcf/Makefile.ebdftopcf \
BDFFILES="${bdffiles}" \
BDFTOPCF_PARAMS="${BDFTOPCF_PARAMS}" \
|| die "Failed to build PCF files"
}
+
+#
+# Public inheritable functions
+#
+font-ebdftopcf_src_compile() {
+ [ -z "${BDFFILES}" ] && BDFFILES="$(find -name '*.bdf')"
+ ebdftopcf ${BDFFILES}
+}
+
+EXPORT_FUNCTIONS src_compile