summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2012-06-06 17:00:09 +0000
committerMike Pagano <mpagano@gentoo.org>2012-06-06 17:00:09 +0000
commit76389f53a19d488ed32113e8fe9e51751d566bd3 (patch)
tree41fd6712150b837fbab71c0d1f83e2d50970014b /eclass/kernel-2.eclass
parentRemoving old 5.3 ebuild (diff)
downloadhistorical-76389f53a19d488ed32113e8fe9e51751d566bd3.tar.gz
historical-76389f53a19d488ed32113e8fe9e51751d566bd3.tar.bz2
historical-76389f53a19d488ed32113e8fe9e51751d566bd3.zip
Move ppc/powerpc fix to after we apply linux patches
Diffstat (limited to 'eclass/kernel-2.eclass')
-rw-r--r--eclass/kernel-2.eclass29
1 files changed, 15 insertions, 14 deletions
diff --git a/eclass/kernel-2.eclass b/eclass/kernel-2.eclass
index c4811ae38968..6ee9bd3529a6 100644
--- a/eclass/kernel-2.eclass
+++ b/eclass/kernel-2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.275 2012/03/17 00:01:59 mpagano Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/kernel-2.eclass,v 1.276 2012/06/06 17:00:09 mpagano Exp $
# Description: kernel.eclass rewrite for a clean base regarding the 2.6
# series of kernel with back-compatibility for 2.4
@@ -578,19 +578,6 @@ universal_unpack() {
# remove all backup files
find . -iname "*~" -exec rm {} \; 2> /dev/null
- # fix a problem on ppc where TOUT writes to /usr/src/linux breaking sandbox
- # only do this for kernel < 2.6.27 since this file does not exist in later
- # kernels
- if [[ -n ${KV_MINOR} && ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} < 2.6.27 ]]
- then
- sed -i \
- -e 's|TOUT := .tmp_gas_check|TOUT := $(T).tmp_gas_check|' \
- "${S}"/arch/ppc/Makefile
- else
- sed -i \
- -e 's|TOUT := .tmp_gas_check|TOUT := $(T).tmp_gas_check|' \
- "${S}"/arch/powerpc/Makefile
- fi
}
unpack_set_extraversion() {
@@ -1155,6 +1142,20 @@ kernel-2_src_unpack() {
cp "${DISTDIR}/${DEBLOB_CHECK_A}" "${T}/deblob-check" || die "cp ${DEBLOB_CHECK_A} failed"
chmod +x "${T}/${DEBLOB_A}" "${T}/deblob-check" || die "chmod deblob scripts failed"
fi
+
+ # fix a problem on ppc where TOUT writes to /usr/src/linux breaking sandbox
+ # only do this for kernel < 2.6.27 since this file does not exist in later
+ # kernels
+ if [[ -n ${KV_MINOR} && ${KV_MAJOR}.${KV_MINOR}.${KV_PATCH} < 2.6.27 ]]
+ then
+ sed -i \
+ -e 's|TOUT := .tmp_gas_check|TOUT := $(T).tmp_gas_check|' \
+ "${S}"/arch/ppc/Makefile
+ else
+ sed -i \
+ -e 's|TOUT := .tmp_gas_check|TOUT := $(T).tmp_gas_check|' \
+ "${S}"/arch/powerpc/Makefile
+ fi
}
kernel-2_src_compile() {