summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-04-09 15:49:46 +0000
committerMarinus Schraal <foser@gentoo.org>2004-04-09 15:49:46 +0000
commit749e8396acc86cc86fa6ddbdcaf07f00d77c74c2 (patch)
tree9c3e9f2284efc59835035344c6f47523af8d8f69 /eclass
parentpatch to initscript to work with dual booting. Patch provided by: Paul Belt ... (diff)
downloadhistorical-749e8396acc86cc86fa6ddbdcaf07f00d77c74c2.tar.gz
historical-749e8396acc86cc86fa6ddbdcaf07f00d77c74c2.tar.bz2
historical-749e8396acc86cc86fa6ddbdcaf07f00d77c74c2.zip
add some code to cleanout gconf stuff
cleanup some output
Diffstat (limited to 'eclass')
-rw-r--r--eclass/gnome2.eclass34
1 files changed, 27 insertions, 7 deletions
diff --git a/eclass/gnome2.eclass b/eclass/gnome2.eclass
index 77535f37efd4..dc93e2ff011b 100644
--- a/eclass/gnome2.eclass
+++ b/eclass/gnome2.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/gnome2.eclass,v 1.38 2004/03/24 22:18:05 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/gnome2.eclass,v 1.39 2004/04/09 15:49:46 foser Exp $
#
# Authors:
# Bruce A. Locke <blocke@shivan.org>
@@ -20,7 +20,7 @@ USE_DESTDIR="" # use make DESTDIR=${D} install rather than einstall
[ `use debug` ] && G2CONF="${G2CONF} --enable-debug=yes"
-DEPEND=">=sys-apps/sed-4"
+DEPEND="${DEPEND} >=sys-apps/sed-4"
gnome2_src_configure() {
elibtoolize ${ELTCONF}
@@ -81,15 +81,29 @@ gnome2_gconf_install() {
then
unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
export GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
- einfo "Installing GNOME 2 GConf Schemas"
+ einfo "Installing GNOME 2 GConf schemas"
cat ${ROOT}/var/db/pkg/*/${PN}-${PVR}/CONTENTS | grep "obj /etc/gconf/schemas" | sed 's:obj \([^ ]*\) .*:\1:' |while read F; do
- echo "DEBUG::gconf install ${F}"
- ${ROOT}/usr/bin/gconftool-2 --makefile-install-rule ${F}
+ # echo "DEBUG::gconf install ${F}"
+ ${ROOT}/usr/bin/gconftool-2 --makefile-install-rule ${F} 1>/dev/null
done
- echo
fi
}
+gnome2_gconf_uninstall() {
+
+ if [ -x ${ROOT}/usr/bin/gconftool-2 ]
+ then
+ unset GCONF_DISABLE_MAKEFILE_SCHEMA_INSTALL
+ export GCONF_CONFIG_SOURCE=`${ROOT}/usr/bin/gconftool-2 --get-default-source`
+ einfo "Uninstalling GNOME 2 GConf schemas"
+ cat ${ROOT}/var/db/pkg/*/${PN}-${PVR}/CONTENTS | grep "obj /etc/gconf/schemas" | sed 's:obj \([^ ]*\) .*:\1:' |while read F; do
+ # echo "DEBUG::gconf install ${F}"
+ ${ROOT}/usr/bin/gconftool-2 --makefile-uninstall-rule ${F} 1>/dev/null
+ done
+ fi
+
+}
+
gnome2_omf_fix() {
# workaround/patch against omf.make or omf-install/Makefile.in
# in order to remove redundant scrollkeeper-updates.
@@ -129,11 +143,17 @@ gnome2_pkg_postinst() {
gnome2_scrollkeeper_update
}
+gnome2_pkg_prerm() {
+
+ gnome2_gconf_uninstall
+
+}
+
gnome2_pkg_postrm() {
gnome2_scrollkeeper_update
}
-EXPORT_FUNCTIONS src_compile src_install pkg_postinst pkg_postrm
+EXPORT_FUNCTIONS src_compile src_install pkg_postinst pkg_prerm pkg_postrm