summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2012-01-21 20:44:28 +0000
committerMichał Górny <mgorny@gentoo.org>2012-01-21 20:44:28 +0000
commit8b204cc3ca40cde88a41611eb8b5b109e9d9a4eb (patch)
tree3ce3fab28730737676c82cd4e6c77f99c19dd140 /eclass
parentInitial commit (as part of #356535 by Satoshi Hayazaki) (diff)
downloadhistorical-8b204cc3ca40cde88a41611eb8b5b109e9d9a4eb.tar.gz
historical-8b204cc3ca40cde88a41611eb8b5b109e9d9a4eb.tar.bz2
historical-8b204cc3ca40cde88a41611eb8b5b109e9d9a4eb.zip
Force autoreconf on user patches only.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog5
-rw-r--r--eclass/autotools-utils.eclass7
2 files changed, 8 insertions, 4 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index ba981e5bfca6..8f315fcc61f6 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for eclass directory
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.100 2012/01/21 19:48:20 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.101 2012/01/21 20:44:28 mgorny Exp $
+
+ 21 Jan 2012; Michał Górny <mgorny@gentoo.org> autotools-utils.eclass:
+ Force autoreconf on user patches only.
21 Jan 2012; Mike Gilbert <floppym@gentoo.org> python.eclass:
Copy python_clean_installation_image from Progress overlay. Thanks Arfrever.
diff --git a/eclass/autotools-utils.eclass b/eclass/autotools-utils.eclass
index e56e5217bff1..7ed6856529e4 100644
--- a/eclass/autotools-utils.eclass
+++ b/eclass/autotools-utils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/autotools-utils.eclass,v 1.44 2012/01/19 21:49:38 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/autotools-utils.eclass,v 1.45 2012/01/21 20:44:28 mgorny Exp $
# @ECLASS: autotools-utils.eclass
# @MAINTAINER:
@@ -360,8 +360,9 @@ autotools-utils_src_prepare() {
local want_autoreconf=${AUTOTOOLS_AUTORECONF}
- touch "${T}"/.autotools-utils.timestamp || die
[[ ${PATCHES} ]] && epatch "${PATCHES[@]}"
+
+ touch "${T}"/.autotools-utils.timestamp || die
epatch_user
if [[ ! ${want_autoreconf} ]]; then
if [[ $(find . -newer "${T}"/.autotools-utils.timestamp \
@@ -369,7 +370,7 @@ autotools-utils_src_prepare() {
-o -name 'configure.ac' \
-o -name 'configure.in' ')' \
-print -quit) ]]; then
- einfo 'Will autoreconfigure due to patches applied.'
+ einfo 'Will autoreconfigure due to user patches applied.'
want_autoreconf=yep
fi
fi