summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMark Loeser <halcy0n@gentoo.org>2010-02-26 05:17:24 +0000
committerMark Loeser <halcy0n@gentoo.org>2010-02-26 05:17:24 +0000
commit9f99808768113a3bf3d7ea0588c8cf9abc0a91e7 (patch)
tree5a0fa7a563126c78d5618e7319f6f02ff74911a8 /eclass
parentRemoved a trailing setupdocs in the setup.py (diff)
downloadhistorical-9f99808768113a3bf3d7ea0588c8cf9abc0a91e7.tar.gz
historical-9f99808768113a3bf3d7ea0588c8cf9abc0a91e7.tar.bz2
historical-9f99808768113a3bf3d7ea0588c8cf9abc0a91e7.zip
Broken with stable versions of bash
Diffstat (limited to 'eclass')
-rw-r--r--eclass/eutils.eclass20
1 files changed, 4 insertions, 16 deletions
diff --git a/eclass/eutils.eclass b/eclass/eutils.eclass
index d8b753e4b906..8fc52129f8da 100644
--- a/eclass/eutils.eclass
+++ b/eclass/eutils.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/eutils.eclass,v 1.334 2010/02/26 03:15:26 abcd Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/eutils.eclass,v 1.335 2010/02/26 05:17:24 halcy0n Exp $
# @ECLASS: eutils.eclass
# @MAINTAINER:
@@ -961,7 +961,6 @@ make_desktop_entry() {
news) type=News;;
nntp) type=News;;
p2p) type=FileTransfer;;
- voip) type=Telephony;;
*) type=;;
esac
type="Network;${type}"
@@ -980,7 +979,7 @@ make_desktop_entry() {
visual*) type=DataVisualization;;
*) type=;;
esac
- type="Education;Science;${type}"
+ type="Science;${type}"
;;
sys)
@@ -992,7 +991,7 @@ make_desktop_entry() {
client) type=WebBrowser;;
*) type=;;
esac
- type="Network;${type}"
+ type="Network"
;;
*)
@@ -1008,17 +1007,6 @@ make_desktop_entry() {
local desktop="${T}/$(echo ${exec} | sed 's:[[:space:]/:]:_:g')-${desktop_name}.desktop"
#local desktop=${T}/${exec%% *:-${desktop_name}}.desktop
- # Don't append another ";" when a valid category value is provided.
- type=${type%;}${type:+;}
-
- eshopts_push -s extglob
- if [[ -n ${icon} && ${icon} != /* && ${icon} == *.@(xpm|png|svg) ]]; then
- ewarn "As described in the Icon Theme Specification, icon file extensions are not"
- ewarn "allowed in .desktop files if the value is not an absolute path."
- icon=${icon%.@(xpm|png|svg)}
- fi
- eshopts_pop
-
cat <<-EOF > "${desktop}"
[Desktop Entry]
Name=${name}
@@ -1027,7 +1015,7 @@ make_desktop_entry() {
Exec=${exec}
TryExec=${exec%% *}
Icon=${icon}
- Categories=${type}
+ Categories=${type};
EOF
[[ ${path} ]] && echo "Path=${path}" >> "${desktop}"