summaryrefslogtreecommitdiff
path: root/eclass
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-05 18:00:21 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-05 18:00:21 +0000
commita5d2458b3ad752c3142607f056c9c87d38928f1b (patch)
tree4499c9312bc417cacd6ac0611aefa8736c71c902 /eclass
parentVersion bump. Fixes an argv splitting bug that can affect some packages (like... (diff)
downloadhistorical-a5d2458b3ad752c3142607f056c9c87d38928f1b.tar.gz
historical-a5d2458b3ad752c3142607f056c9c87d38928f1b.tar.bz2
historical-a5d2458b3ad752c3142607f056c9c87d38928f1b.zip
Simplify ${D%/}/ to ${D}; PMS says ${D} always has a trailing slash, and it works without a trailing slash anyway.
Diffstat (limited to 'eclass')
-rw-r--r--eclass/ChangeLog6
-rw-r--r--eclass/python-distutils-ng.eclass4
2 files changed, 7 insertions, 3 deletions
diff --git a/eclass/ChangeLog b/eclass/ChangeLog
index 5399286dfedf..c2f203feff01 100644
--- a/eclass/ChangeLog
+++ b/eclass/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for eclass directory
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.237 2012/05/04 15:39:29 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/ChangeLog,v 1.238 2012/05/05 18:00:21 floppym Exp $
+
+ 05 May 2012; Mike Gilbert <floppym@gentoo.org> python-distutils-ng.eclass:
+ Simplify ${D%/}/ to ${D}; PMS says ${D} always has a trailing slash, and it
+ works without a trailing slash anyway.
04 May 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
xorg-2.eclass:
diff --git a/eclass/python-distutils-ng.eclass b/eclass/python-distutils-ng.eclass
index fdbf2676062e..50339bc13681 100644
--- a/eclass/python-distutils-ng.eclass
+++ b/eclass/python-distutils-ng.eclass
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/eclass/python-distutils-ng.eclass,v 1.16 2012/05/04 08:31:43 nelchael Exp $
+# $Header: /var/cvsroot/gentoo-x86/eclass/python-distutils-ng.eclass,v 1.17 2012/05/05 18:00:21 floppym Exp $
# @ECLASS: python-distutils-ng
# @MAINTAINER:
@@ -181,7 +181,7 @@ _python-distutils-ng_default_distutils_install() {
unset PYTHONDONTWRITEBYTECODE
[[ -n "${PYTHON_DISABLE_COMPILATION}" ]] && compile_flags="--no-compile"
- "${PYTHON}" setup.py install ${compile_flags} --root="${D%/}/" || die
+ "${PYTHON}" setup.py install ${compile_flags} --root="${D}" || die
}
# @FUNCTION: python-distutils-ng_redoscript