summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2004-06-28 13:48:12 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2004-06-28 13:48:12 +0000
commit89db8be4ab887631228468782c77a2671b1b12ae (patch)
tree9ce268748d417e8f679ddd390d0176d38e349e51 /games-action/d2x
parentadd mono useflag for libbtctl (diff)
downloadhistorical-89db8be4ab887631228468782c77a2671b1b12ae.tar.gz
historical-89db8be4ab887631228468782c77a2671b1b12ae.tar.bz2
historical-89db8be4ab887631228468782c77a2671b1b12ae.zip
Fixing cdinstall and closing bug #55417.
Diffstat (limited to 'games-action/d2x')
-rw-r--r--games-action/d2x/ChangeLog5
-rw-r--r--games-action/d2x/Manifest4
-rw-r--r--games-action/d2x/d2x-0.2.5-r1.ebuild22
3 files changed, 18 insertions, 13 deletions
diff --git a/games-action/d2x/ChangeLog b/games-action/d2x/ChangeLog
index 93bac7d10689..29a46c3ed106 100644
--- a/games-action/d2x/ChangeLog
+++ b/games-action/d2x/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-action/d2x
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.6 2004/06/28 04:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/ChangeLog,v 1.7 2004/06/28 13:48:12 wolf31o2 Exp $
+
+ 28 Jun 2004; Chris Gianelloni <wolf31o2@gentoo.org> d2x-0.2.5-r1.ebuild:
+ Fixing cdinstall and closing bug #55417.
27 Jun 2004; Aron Griffis <agriffis@gentoo.org> d2x-0.2.5-r1.ebuild,
d2x-0.2.5.ebuild:
diff --git a/games-action/d2x/Manifest b/games-action/d2x/Manifest
index 71af0a81871b..75d3b5b77d14 100644
--- a/games-action/d2x/Manifest
+++ b/games-action/d2x/Manifest
@@ -1,6 +1,6 @@
MD5 cd93d202d6e52be0b2e1819f094fc4d0 d2x-0.2.5.ebuild 1978
-MD5 08f1eeba5d778c7f034f9b81e8d6e667 ChangeLog 814
-MD5 6e9b1f6772cc7594a99a717d5fb0d352 d2x-0.2.5-r1.ebuild 2602
+MD5 aa90ea44d1a800603eace559dfba7203 ChangeLog 933
+MD5 f94e6f1995ac783e57629d931360e747 d2x-0.2.5-r1.ebuild 2657
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 499b24f4949333a0c04d1177aa3213e5 files/0.2.5-shellscripts.patch 747
MD5 b298d324cbce31e8cc4779c765fabc4d files/digest-d2x-0.2.5 123
diff --git a/games-action/d2x/d2x-0.2.5-r1.ebuild b/games-action/d2x/d2x-0.2.5-r1.ebuild
index a86d98243771..c4199d37397e 100644
--- a/games-action/d2x/d2x-0.2.5-r1.ebuild
+++ b/games-action/d2x/d2x-0.2.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.2 2004/06/28 04:25:14 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/d2x/d2x-0.2.5-r1.ebuild,v 1.3 2004/06/28 13:48:12 wolf31o2 Exp $
inherit flag-o-matic eutils games
@@ -8,7 +8,7 @@ DATAFILE="d2shar10"
DESCRIPTION="Descent 2"
HOMEPAGE="http://icculus.org/d2x/"
SRC_URI="http://icculus.org/d2x/src/${P}.tar.gz
- http://icculus.org/d2x/data/${DATAFILE}.tar.gz"
+ !cdinstall? ( http://icculus.org/d2x/data/${DATAFILE}.tar.gz )"
LICENSE="GPL-2"
SLOT="0"
@@ -25,15 +25,17 @@ DEPEND="${RDEPEND}
x86? ( dev-lang/nasm )"
pkg_setup() {
- if ! [ -e ${DISTDIR}/descent2.sow ] ; then
+ if use cdinstall ; then
+ if ! [ -e ${DISTDIR}/descent2.sow ] ; then
cdrom_get_cds d2data
- if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
- export CDROM_ROOT=${CDROM_ROOT}/d2data
- einfo "Found the original Descent2 CD"
- einfo "Copying descent2.sow to ${DISTDIR}"
- cp ${CDROM_ROOT}/descent2.sow ${DISTDIR}/descent2.sow
- else
- die "You need the original Descent2 CD"
+ if [ -e ${CDROM_ROOT}/d2data/descent2.sow ] ; then
+ export CDROM_ROOT=${CDROM_ROOT}/d2data
+ einfo "Found the original Descent2 CD"
+ einfo "Copying descent2.sow to ${DISTDIR}"
+ cp ${CDROM_ROOT}/descent2.sow ${DISTDIR}/descent2.sow
+ else
+ die "You need the original Descent2 CD"
+ fi
fi
fi
games_pkg_setup