summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-03 10:02:41 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-03 10:02:41 +0000
commite396202fe4cf0442fc31103c69311249e2836ad7 (patch)
tree3342a899aa2409304eb178485dbf6c6bb888a1d7 /games-action/glaxium
parentStable sparc, x86. (diff)
downloadhistorical-e396202fe4cf0442fc31103c69311249e2836ad7.tar.gz
historical-e396202fe4cf0442fc31103c69311249e2836ad7.tar.bz2
historical-e396202fe4cf0442fc31103c69311249e2836ad7.zip
added the rc patch from Loz Hygate via bug #58289
Diffstat (limited to 'games-action/glaxium')
-rw-r--r--games-action/glaxium/ChangeLog6
-rw-r--r--games-action/glaxium/Manifest9
-rw-r--r--games-action/glaxium/files/0.5-rc.patch10
-rw-r--r--games-action/glaxium/glaxium-0.5.ebuild21
4 files changed, 32 insertions, 14 deletions
diff --git a/games-action/glaxium/ChangeLog b/games-action/glaxium/ChangeLog
index d585e19bc418..dd91652abccb 100644
--- a/games-action/glaxium/ChangeLog
+++ b/games-action/glaxium/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-action/glaxium
# Copyright 2000-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.8 2004/06/25 03:22:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/ChangeLog,v 1.9 2004/09/03 10:02:41 mr_bones_ Exp $
+
+ 03 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> +files/0.5-rc.patch,
+ glaxium-0.5.ebuild:
+ added the rc patch from Loz Hygate via bug #58289
19 Apr 2004; Chris Gianelloni <wolf31o2@gentoo.org> glaxium-0.5.ebuild:
Added IUSE.
diff --git a/games-action/glaxium/Manifest b/games-action/glaxium/Manifest
index 125690e089b1..b8eeefec730e 100644
--- a/games-action/glaxium/Manifest
+++ b/games-action/glaxium/Manifest
@@ -1,7 +1,8 @@
-MD5 b46732f8cd780b10bdb0779855ca1d84 glaxium-0.5.ebuild 1219
-MD5 c0c8af0055910037da9a90c9d588ea81 ChangeLog 887
+MD5 96d0e463d6cd4410db81f6e3106455f4 ChangeLog 1039
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 0ab557289a7610d1984e43634d0be398 files/digest-glaxium-0.5 64
+MD5 697e90d1acbbadbd62a2afdc32a8427b glaxium-0.5.ebuild 1294
+MD5 ab479510f01767b032042d1d964670cd files/0.5-rc.patch 277
MD5 ef110a66a7eac137dd399eca0a4aede3 files/0.5-glx.patch 2299
-MD5 143ef6a6f05c1f89830306e8c34550df files/0.5-another-glx.patch 776
+MD5 0ab557289a7610d1984e43634d0be398 files/digest-glaxium-0.5 64
MD5 ccccdc44cf5870eff196d3409b1a9f30 files/glx-test.c 98
+MD5 143ef6a6f05c1f89830306e8c34550df files/0.5-another-glx.patch 776
diff --git a/games-action/glaxium/files/0.5-rc.patch b/games-action/glaxium/files/0.5-rc.patch
new file mode 100644
index 000000000000..826a00a482a0
--- /dev/null
+++ b/games-action/glaxium/files/0.5-rc.patch
@@ -0,0 +1,10 @@
+--- variables.cpp.orig 2004-08-20 01:04:34.000000000 -0700
++++ variables.cpp 2004-08-20 01:05:19.000000000 -0700
+@@ -453,6 +453,7 @@
+ static char strReturn[1024];
+ strcpy(strReturn, getenv("HOME"));
+ strcat(strReturn, "/.glaxiumrc");
++ return strReturn;
+ #endif
+ }
+
diff --git a/games-action/glaxium/glaxium-0.5.ebuild b/games-action/glaxium/glaxium-0.5.ebuild
index aeb0f324a72f..7c55c09888b9 100644
--- a/games-action/glaxium/glaxium-0.5.ebuild
+++ b/games-action/glaxium/glaxium-0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.10 2004/06/25 03:22:30 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/glaxium/glaxium-0.5.ebuild,v 1.11 2004/09/03 10:02:41 mr_bones_ Exp $
inherit eutils flag-o-matic gcc games
@@ -21,29 +21,32 @@ DEPEND=">=media-libs/libsdl-1.1.5
virtual/glut
>=media-libs/libpng-1.0.0"
-S=${WORKDIR}/${PN}_${PV}
+S="${WORKDIR}/${PN}_${PV}"
src_unpack() {
unpack ${A}
cd ${S}
$(gcc-getCXX) ${FILESDIR}/glx-test.c >& /dev/null
if [ $? -ne 0 ] ; then
- epatch ${FILESDIR}/${PV}-glx.patch
+ epatch "${FILESDIR}/${PV}-glx.patch"
append-flags -DGL_GLEXT_LEGACY
fi
- has_version '>=media-video/nvidia-glx-1.0.5328' && epatch ${FILESDIR}/${PV}-another-glx.patch
+ has_version '>=media-video/nvidia-glx-1.0.5328' \
+ && epatch "${FILESDIR}/${PV}-another-glx.patch"
+ epatch "${FILESDIR}/${PV}-rc.patch"
}
src_compile() {
- egamesconf --datadir=${GAMES_DATADIR_BASE} || die
- emake || die
+ egamesconf \
+ --datadir="${GAMES_DATADIR_BASE}" || die
+ emake || die "emake failed"
}
src_install() {
- dodir ${GAMES_BINDIR}
+ dodir "${GAMES_BINDIR}"
egamesinstall \
- exec_prefix=${D}/${GAMES_PREFIX} \
- datadir=${D}/${GAMES_DATADIR_BASE} \
+ exec_prefix="${D}/${GAMES_PREFIX}" \
+ datadir="${D}/${GAMES_DATADIR_BASE}" \
|| die
dodoc README.txt CHANGES.txt
prepgamesdirs