summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:08:54 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-24 22:08:54 +0000
commit4157ec65f5008d6483771139900999058ce458fb (patch)
tree43ced59574de4b4c11210c96e9df80ec8c5602d6 /games-action/heretic2/heretic2-1.06c.ebuild
parentBug 152049, missing dep on media-libs/jpeg. Thanks ECP (diff)
downloadhistorical-4157ec65f5008d6483771139900999058ce458fb.tar.gz
historical-4157ec65f5008d6483771139900999058ce458fb.tar.bz2
historical-4157ec65f5008d6483771139900999058ce458fb.zip
Moved cdrom_get_cds to src_unpack since binary packages don't require the original media to install as well as some general cleanup.
Package-Manager: portage-2.1.2_pre3-r5
Diffstat (limited to 'games-action/heretic2/heretic2-1.06c.ebuild')
-rw-r--r--games-action/heretic2/heretic2-1.06c.ebuild21
1 files changed, 9 insertions, 12 deletions
diff --git a/games-action/heretic2/heretic2-1.06c.ebuild b/games-action/heretic2/heretic2-1.06c.ebuild
index fac144c81b3c..5ec4160d32b4 100644
--- a/games-action/heretic2/heretic2-1.06c.ebuild
+++ b/games-action/heretic2/heretic2-1.06c.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/heretic2-1.06c.ebuild,v 1.1 2006/10/03 22:32:24 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/heretic2/heretic2-1.06c.ebuild,v 1.2 2006/10/24 22:08:54 wolf31o2 Exp $
inherit eutils games
@@ -24,13 +24,11 @@ RDEPEND="virtual/opengl"
S=${WORKDIR}
GAMES_CHECK_LICENSE="yes"
-
-pkg_setup() {
- games_pkg_setup
- cdrom_get_cds bin/x86/glibc-2.1/${PN}
-}
+dir=${GAMES_PREFIX_OPT}/${PN}
+Ddir=${D}/${dir}
src_unpack() {
+ cdrom_get_cds bin/x86/glibc-2.1/${PN}
mkdir ${A}
local f
@@ -42,7 +40,6 @@ src_unpack() {
src_install() {
cd "${CDROM_ROOT}"
- local dir=${GAMES_PREFIX_OPT}/${PN}
insinto "${dir}"
doins -r base help Manual.html README README.more || die "doins failed"
@@ -50,11 +47,11 @@ src_install() {
exeinto "${dir}"
doexe bin/x86/glibc-2.1/${PN} || die "doexe failed"
- games_make_wrapper ${PN} ./${PN} "${dir}" .
+ games_make_wrapper ${PN} ./${PN} "${dir}" "${dir}"
newicon icon.xpm ${PN}.xpm
make_desktop_entry ${PN} "Heretic II" ${PN}.xpm
- cd "${D}/${dir}"
+ cd "${Ddir}"
ln -s "${CDROM_ROOT}"/*.gz .
unpack ./*.gz
rm -f *.gz
@@ -62,12 +59,12 @@ src_install() {
local d
for d in "${S}"/* ; do
cd "${d}"
- loki_patch patch.dat "${D}/${dir}" || die "loki_patch ${d} failed"
+ loki_patch patch.dat "${Ddir}" || die "loki_patch ${d} failed"
done
- rmdir "${D}/${dir}"/gl_drivers
+ rmdir "${Ddir}"/gl_drivers
sed -i '128i set gl_driver "/usr/lib/libGL.so"' \
- "${D}/${dir}"/base/default.cfg || die "sed failed"
+ "${Ddir}"/base/default.cfg || die "sed failed"
prepgamesdirs
}