summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2007-03-14 20:53:28 +0000
committerTristan Heaven <tristan@gentoo.org>2007-03-14 20:53:28 +0000
commit8d628ff017ea47291459308bb014656f20deba59 (patch)
tree93518967883546670b214cf342358537f8bef6f0 /games-action/shootingstar/shootingstar-1.2.0.ebuild
parentRemoved old ebuilds. (diff)
downloadhistorical-8d628ff017ea47291459308bb014656f20deba59.tar.gz
historical-8d628ff017ea47291459308bb014656f20deba59.tar.bz2
historical-8d628ff017ea47291459308bb014656f20deba59.zip
Install menu entry, bug #159764
Package-Manager: portage-2.1.2.2
Diffstat (limited to 'games-action/shootingstar/shootingstar-1.2.0.ebuild')
-rw-r--r--games-action/shootingstar/shootingstar-1.2.0.ebuild14
1 files changed, 8 insertions, 6 deletions
diff --git a/games-action/shootingstar/shootingstar-1.2.0.ebuild b/games-action/shootingstar/shootingstar-1.2.0.ebuild
index 9f67c851cc4c..d52c228828f1 100644
--- a/games-action/shootingstar/shootingstar-1.2.0.ebuild
+++ b/games-action/shootingstar/shootingstar-1.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.4 2006/01/28 21:19:10 joshuabaergen Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/shootingstar/shootingstar-1.2.0.ebuild,v 1.5 2007/03/14 20:53:28 nyhm Exp $
inherit eutils games
@@ -15,18 +15,20 @@ IUSE=""
DEPEND="virtual/opengl
virtual/glu
- >=media-libs/libsdl-1.2
+ media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-image"
src_unpack() {
unpack ${A}
- cd ${S}
- epatch "${FILESDIR}/1.2.0-gcc34.patch"
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-gcc34.patch
}
src_install () {
- make DESTDIR=${D} install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
+ newicon data/textures/body1.png ${PN}.png
+ make_desktop_entry ${PN} "Shooting Star"
dodoc AUTHORS ChangeLog NEWS README TODO
prepgamesdirs
}