summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-08 04:09:24 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-08 04:09:24 +0000
commitcc581df0de07ac3ae2dd97226bf9a99e3fc92207 (patch)
tree695f80217ac008afa39ebe4f2ce65e963253ac68 /games-action/xshipwars
parentpatch to work around a gcc-3.3 bug #85780 (diff)
downloadhistorical-cc581df0de07ac3ae2dd97226bf9a99e3fc92207.tar.gz
historical-cc581df0de07ac3ae2dd97226bf9a99e3fc92207.tar.bz2
historical-cc581df0de07ac3ae2dd97226bf9a99e3fc92207.zip
patch to work around a gcc-3.3 bug #85780
Package-Manager: portage-2.0.51.19
Diffstat (limited to 'games-action/xshipwars')
-rw-r--r--games-action/xshipwars/Manifest3
-rw-r--r--games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch31
-rw-r--r--games-action/xshipwars/xshipwars-1.34.0.ebuild4
3 files changed, 36 insertions, 2 deletions
diff --git a/games-action/xshipwars/Manifest b/games-action/xshipwars/Manifest
index 6c9595291ca2..d19ab6c64e61 100644
--- a/games-action/xshipwars/Manifest
+++ b/games-action/xshipwars/Manifest
@@ -1,5 +1,6 @@
MD5 6e8801a4a0a9cc9b1f4f3140ba2aef8b ChangeLog 1436
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
-MD5 413cee600291605ca9df1f3a83b24d57 xshipwars-1.34.0.ebuild 2632
+MD5 8f72844a3ae1383a99a86f9f2ffe0247 xshipwars-1.34.0.ebuild 2682
MD5 825e4e161401b86551eb3985d7fdc357 files/digest-xshipwars-1.34.0 327
MD5 810c3eb40cc4e406109ac3f0e33b3fa9 files/xshipwars-1.34.0-gcc3.patch 1338
+MD5 0bc5c432a5c0eec30c650e255deadf48 files/xshipwars-1.34.0-gcc33.patch 889
diff --git a/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch b/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch
new file mode 100644
index 000000000000..f64de08f4d2a
--- /dev/null
+++ b/games-action/xshipwars/files/xshipwars-1.34.0-gcc33.patch
@@ -0,0 +1,31 @@
+Work around a gcc-3.3.x bug where redefining prototypes with different
+__THROW / attribute(nonnull) markings throws an error:
+
+string.cpp:31: error: declaration of `char* strcasestr(const char*, const char*)' throws different exceptions
+../include/string.h:46: error: than previous declaration `char* strcasestr(const char*, const char*) throw ()'
+
+basically we just use the glibc strcasestr() instead of the internal one.
+
+http://bugs.gentoo.org/show_bug.cgi?id=85780
+
+--- global/string.cpp
++++ global/string.cpp
+@@ -37,3 +37,5 @@
+ #endif
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle);
++#endif
+ int strpfx(const char *s, const char *pfx);
+@@ -221,3 +224,4 @@
+ */
++#ifndef _GNU_SOURCE
+ char *strcasestr(const char *haystack, const char *needle)
+ {
+@@ -274,6 +277,7 @@
+
+ return(NULL);
+ }
++#endif
+
+ /*
+ * Checks if string pfx is a prefix of string s.
diff --git a/games-action/xshipwars/xshipwars-1.34.0.ebuild b/games-action/xshipwars/xshipwars-1.34.0.ebuild
index b8e5c3b91ed3..897c9318ed83 100644
--- a/games-action/xshipwars/xshipwars-1.34.0.ebuild
+++ b/games-action/xshipwars/xshipwars-1.34.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-1.34.0.ebuild,v 1.11 2005/03/19 18:20:23 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/xshipwars/xshipwars-1.34.0.ebuild,v 1.12 2005/04/08 04:09:24 vapier Exp $
inherit toolchain-funcs eutils games
@@ -25,6 +25,8 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-gcc33.patch
}
src_compile() {