summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-05-17 12:50:57 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-05-17 12:50:57 +0000
commit209f81d32ca37e5bb1147357f9a584d6ab99749b (patch)
treed9a6f30414e56115dec25e5b31ff5d2963250671 /games-arcade/opentyrian/opentyrian-20110517.ebuild
parentVersion bump (diff)
downloadhistorical-209f81d32ca37e5bb1147357f9a584d6ab99749b.tar.gz
historical-209f81d32ca37e5bb1147357f9a584d6ab99749b.tar.bz2
historical-209f81d32ca37e5bb1147357f9a584d6ab99749b.zip
Bump to new snapshot, as requested by Torsten Kaiser in bug #333011. Port to EAPI=3.
Package-Manager: portage-2.1.9.49/cvs/Linux x86_64
Diffstat (limited to 'games-arcade/opentyrian/opentyrian-20110517.ebuild')
-rw-r--r--games-arcade/opentyrian/opentyrian-20110517.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/games-arcade/opentyrian/opentyrian-20110517.ebuild b/games-arcade/opentyrian/opentyrian-20110517.ebuild
new file mode 100644
index 000000000000..e4c7697d0752
--- /dev/null
+++ b/games-arcade/opentyrian/opentyrian-20110517.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/opentyrian/opentyrian-20110517.ebuild,v 1.1 2011/05/17 12:50:57 chainsaw Exp $
+
+inherit base games
+
+DESCRIPTION="Open-source port of the DOS game Tyrian, vertical scrolling shooter"
+HOMEPAGE="http://code.google.com/p/opentyrian/"
+SRC_URI="http://darklomax.org/tyrian/tyrian21.zip
+ mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+S="${WORKDIR}/${PN}"
+
+RDEPEND="media-libs/libsdl
+ media-libs/sdl-net"
+# Yes, mercurial is needed to set the build version stamp.
+DEPEND="${RDEPEND}
+ app-arch/unzip
+ dev-vcs/mercurial"
+PATCHES=(
+ "${FILESDIR}/${PV}-datapath.diff"
+ "${FILESDIR}/${PV}-cflag-idiocy.diff"
+)
+
+src_compile() {
+ emake DATA_PATH="${GAMES_DATADIR}/${PN}" || die "Compilation failed"
+}
+
+src_install() {
+ newgamesbin opentyrian tyrian || die "Failed to install game binary"
+ dodoc CREDITS NEWS README || die "Failed to install documentation"
+ domenu linux/opentyrian.desktop || die "Failed to install desktop file"
+ doicon linux/icons/* || die "Failed to install program icons"
+ insinto "${GAMES_DATADIR}/${PN}"
+ cd "${WORKDIR}/tyrian21"
+ doins * || die "Failed to install game data"
+ prepgamesdirs
+}