summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-29 22:51:51 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-29 22:51:51 +0000
commitc422ea5fe9a71b83a014144992f7d8e9c0babc0d (patch)
treedbca8ff73f0b62252ad12774c03a408e44ad13e2 /games-arcade/sdl-sopwith
parentinitial commit (bug 34723) (diff)
downloadhistorical-c422ea5fe9a71b83a014144992f7d8e9c0babc0d.tar.gz
historical-c422ea5fe9a71b83a014144992f7d8e9c0babc0d.tar.bz2
historical-c422ea5fe9a71b83a014144992f7d8e9c0babc0d.zip
initial commit (bug 34723)
Diffstat (limited to 'games-arcade/sdl-sopwith')
-rw-r--r--games-arcade/sdl-sopwith/Manifest4
-rw-r--r--games-arcade/sdl-sopwith/files/digest-sdl-sopwith-1.7.11
-rw-r--r--games-arcade/sdl-sopwith/metadata.xml9
-rw-r--r--games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild32
4 files changed, 45 insertions, 1 deletions
diff --git a/games-arcade/sdl-sopwith/Manifest b/games-arcade/sdl-sopwith/Manifest
index bb31f37c9362..2f7705e6c8cb 100644
--- a/games-arcade/sdl-sopwith/Manifest
+++ b/games-arcade/sdl-sopwith/Manifest
@@ -1,2 +1,4 @@
-MD5 5c6693b3330097fcac2f32f97b6db272 sdl-sopwith-1.7.1.ebuild 492
+MD5 3d6c103164cff9a0a14b3f0867ccce4a sdl-sopwith-1.7.1.ebuild 879
+MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 6b2c051577f07b48ad8756efb01336e4 ChangeLog 446
MD5 e35cc5cd710dd0d0c12d63304ca5b0a1 files/digest-sdl-sopwith-1.7.1 69
diff --git a/games-arcade/sdl-sopwith/files/digest-sdl-sopwith-1.7.1 b/games-arcade/sdl-sopwith/files/digest-sdl-sopwith-1.7.1
new file mode 100644
index 000000000000..7dbbdded81e6
--- /dev/null
+++ b/games-arcade/sdl-sopwith/files/digest-sdl-sopwith-1.7.1
@@ -0,0 +1 @@
+MD5 bc66c80c83b14d48b60ba263403dba9a sdl_sopwith-1.7.1.tar.gz 176774
diff --git a/games-arcade/sdl-sopwith/metadata.xml b/games-arcade/sdl-sopwith/metadata.xml
new file mode 100644
index 000000000000..1cef6e243af3
--- /dev/null
+++ b/games-arcade/sdl-sopwith/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+<maintainer>
+<email>games@gentoo.org</email>
+<name>Games Team</name>
+</maintainer>
+</pkgmetadata>
diff --git a/games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild b/games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild
new file mode 100644
index 000000000000..e62910a44864
--- /dev/null
+++ b/games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-arcade/sdl-sopwith/sdl-sopwith-1.7.1.ebuild,v 1.1 2003/11/29 22:51:50 mr_bones_ Exp $
+
+inherit games
+
+MY_P="${P/-/_}"
+S="${WORKDIR}/${MY_P}"
+DESCRIPTION="Port of the classic Sopwith game using LibSDL"
+HOMEPAGE="http://sdl-sopwith.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.1.3
+ dev-libs/atk
+ x11-libs/pango
+ >=x11-libs/gtk+-2
+ >=dev-libs/glib-2
+ dev-util/pkgconfig
+ media-libs/gdk-pixbuf
+ >=media-libs/freetype-2"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog FAQ NEWS README TODO doc/*txt || die "dodoc failed"
+ rm -rf "${D}/usr/games/share/"
+ prepgamesdirs
+}