summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-06-28 05:36:39 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-06-28 05:36:39 +0000
commit7317abf62beaa79bbc938def0bf03ff23c012b04 (patch)
tree514dbd0fd208e0b36146124a5f5b3ce401b5f1c9 /games-board/domination
parentVersion bump (diff)
downloadhistorical-7317abf62beaa79bbc938def0bf03ff23c012b04.tar.gz
historical-7317abf62beaa79bbc938def0bf03ff23c012b04.tar.bz2
historical-7317abf62beaa79bbc938def0bf03ff23c012b04.zip
initial commit; package renamed from jrisk
Package-Manager: portage-2.1.10.65/cvs/Linux x86_64
Diffstat (limited to 'games-board/domination')
-rw-r--r--games-board/domination/ChangeLog10
-rw-r--r--games-board/domination/Manifest4
-rw-r--r--games-board/domination/domination-1.1.0.9.ebuild53
-rw-r--r--games-board/domination/metadata.xml5
4 files changed, 72 insertions, 0 deletions
diff --git a/games-board/domination/ChangeLog b/games-board/domination/ChangeLog
new file mode 100644
index 000000000000..eb55332bbdd9
--- /dev/null
+++ b/games-board/domination/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for games-board/domination
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/domination/ChangeLog,v 1.1 2012/06/28 05:36:39 mr_bones_ Exp $
+
+*domination-1.1.0.9 (28 Jun 2012)
+
+ 28 Jun 2012; Michael Sterrett <mr_bones_@gentoo.org>
+ +domination-1.1.0.9.ebuild, +metadata.xml:
+ initial commit; package renamed from jrisk
+
diff --git a/games-board/domination/Manifest b/games-board/domination/Manifest
new file mode 100644
index 000000000000..39339f1405b8
--- /dev/null
+++ b/games-board/domination/Manifest
@@ -0,0 +1,4 @@
+DIST Domination_1.1.0.9.zip 5924122 RMD160 63399f8d36c783fed97b228dd4fbca45c5431da3 SHA1 439893b551548bb5be7e2c2c68b5014473c8c1ce SHA256 cce4f422bb00dcaca9face801494638b3f2d08d0041477b7f7a1f9849efe89af
+EBUILD domination-1.1.0.9.ebuild 1306 RMD160 82f35b36cd5f52d49dc4ea055f8525851ae2dc46 SHA1 e671df4cce9563660ac82c2ceb23dbd595f46375 SHA256 28f47d5bbfb09c19a752bec7c0005e01a870be68658ed6186d88ab370fb6612a
+MISC ChangeLog 401 RMD160 c997f5374c45990b082e124be9c5ef7c5e8f65eb SHA1 21090f5c709be50f69d7666c9f4de2807c2848ed SHA256 662ce9d84c9f4e73e81b927f1317bbfff96630d1edf07da164855d4d713d7be5
+MISC metadata.xml 158 RMD160 cbd9984bb6b426c8c9cee5022fe0a26261612fea SHA1 be5251fa1dacef5c41b74761bb1c8c54fb633b9e SHA256 1423a4fdd4a79b1728a2056d9e300f7e1074253095d82726218d9e9b953888a3
diff --git a/games-board/domination/domination-1.1.0.9.ebuild b/games-board/domination/domination-1.1.0.9.ebuild
new file mode 100644
index 000000000000..ecf294e40165
--- /dev/null
+++ b/games-board/domination/domination-1.1.0.9.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/domination/domination-1.1.0.9.ebuild,v 1.1 2012/06/28 05:36:39 mr_bones_ Exp $
+
+inherit eutils java-pkg-2 java-ant-2 games
+
+DESCRIPTION="The well-known board game, written in java"
+HOMEPAGE="http://domination.sourceforge.net"
+SRC_URI="mirror://sourceforge/domination/Domination_${PV}.zip"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=virtual/jre-1.4"
+DEPEND=">=virtual/jdk-1.4
+ app-arch/unzip"
+
+S=${WORKDIR}/Domination
+
+pkg_setup() {
+ games_pkg_setup
+ java-pkg-2_pkg_setup
+}
+
+EANT_BUILD_TARGET="game"
+
+src_compile() {
+ java-pkg-2_src_compile
+}
+
+src_install() {
+ mkdir -p ${D}${GAMES_PREFIX}/bin
+ cp ${S}/FlashGUI.sh ${D}${GAMES_PREFIX}/bin/${PN} \
+ || die "copy failed"
+ sed -i \
+ -e "s|cd.*|cd ${GAMES_DATADIR}/${PN}|" \
+ ${D}${GAMES_PREFIX}/bin/${PN} \
+ || die "sed failed"
+ chmod +x ${D}${GAMES_PREFIX}/bin/${PN} \
+ || die "chmod failed"
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r ${S}/* || die "doins failed"
+ rm -f "${D}${GAMES_DATADIR}"/${PN}/*.cmd || die
+ java-pkg_regjar "${D}/${GAMES_DATADIR}/${PN}"/*.jar
+
+ newicon resources/icon.png ${PN}.png
+ make_desktop_entry ${PN} "Domination"
+
+ prepgamesdirs
+}
diff --git a/games-board/domination/metadata.xml b/games-board/domination/metadata.xml
new file mode 100644
index 000000000000..d3c2cc926f0b
--- /dev/null
+++ b/games-board/domination/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>games</herd>
+</pkgmetadata>