summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-04-13 09:44:22 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-04-13 09:44:22 +0000
commitdf6a63b2659c29e8c5c03669be7aa1d3c2e94999 (patch)
tree12b58b8d1467f28ab8c842808536f82d78e9e8e0 /games-board
parentnew revision with patch to work with device-mapper + dep (diff)
downloadhistorical-df6a63b2659c29e8c5c03669be7aa1d3c2e94999.tar.gz
historical-df6a63b2659c29e8c5c03669be7aa1d3c2e94999.tar.bz2
historical-df6a63b2659c29e8c5c03669be7aa1d3c2e94999.zip
games.eclass already inherits eutils; less RDEPEND; use flags tidy
Diffstat (limited to 'games-board')
-rw-r--r--games-board/gnushogi/ChangeLog7
-rw-r--r--games-board/gnushogi/Manifest8
-rw-r--r--games-board/gnushogi/gnushogi-1.3.ebuild21
3 files changed, 21 insertions, 15 deletions
diff --git a/games-board/gnushogi/ChangeLog b/games-board/gnushogi/ChangeLog
index c5668ac3225a..5f57d7291c4f 100644
--- a/games-board/gnushogi/ChangeLog
+++ b/games-board/gnushogi/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-board/gnushogi
-# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/ChangeLog,v 1.3 2004/01/02 22:30:20 mr_bones_ Exp $
+# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/ChangeLog,v 1.4 2004/04/13 09:44:22 mr_bones_ Exp $
+
+ 13 Apr 2004; Michael Sterrett <mr_bones_@gentoo.org> gnushogi-1.3.ebuild:
+ games.eclass already inherits eutils; less RDEPEND; use flags tidy
02 Jan 2004; Michael Sterrett <mr_bones_@gentoo.org> gnushogi-1.3.ebuild:
Add errno patch from edi via bug 37013; also, support X use better and sed in
diff --git a/games-board/gnushogi/Manifest b/games-board/gnushogi/Manifest
index 564ddd31712e..d944f44c3f2c 100644
--- a/games-board/gnushogi/Manifest
+++ b/games-board/gnushogi/Manifest
@@ -1,5 +1,5 @@
-MD5 a46c4bdecc0df352e8f7735ee4e6e37b files/digest-gnushogi-1.3 64
-MD5 97c87cb301c5365d234901fe7ea9456d files/1.3-errno.patch 304
-MD5 7b06c8f391918937c71f2f40d7eb2cfc ChangeLog 783
-MD5 7807cfdf63dcaa958afcf295fe08e15e gnushogi-1.3.ebuild 1267
+MD5 2ad425288efc3f775c9da40677cdb664 ChangeLog 929
+MD5 67f6375f6ec3f4186b85fe992da958e1 gnushogi-1.3.ebuild 1288
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 97c87cb301c5365d234901fe7ea9456d files/1.3-errno.patch 304
+MD5 a46c4bdecc0df352e8f7735ee4e6e37b files/digest-gnushogi-1.3 64
diff --git a/games-board/gnushogi/gnushogi-1.3.ebuild b/games-board/gnushogi/gnushogi-1.3.ebuild
index 7324de944105..7b2d81ad0f77 100644
--- a/games-board/gnushogi/gnushogi-1.3.ebuild
+++ b/games-board/gnushogi/gnushogi-1.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/gnushogi-1.3.ebuild,v 1.2 2004/01/02 22:30:20 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-board/gnushogi/gnushogi-1.3.ebuild,v 1.3 2004/04/13 09:44:22 mr_bones_ Exp $
-inherit eutils games
+inherit games
DESCRIPTION="Japanese version of chess (commandline + X-Version)"
HOMEPAGE="http://www.gnu.org/directory/games/gnushogi.html"
@@ -13,10 +13,13 @@ SLOT="0"
KEYWORDS="x86"
IUSE="X"
-DEPEND=">=sys-devel/bison-1.34
- >=sys-devel/flex-2.5
- >=sys-apps/sed-4
+RDEPEND="virtual/glibc
+ sys-libs/ncurses
X? ( virtual/x11 )"
+DEPEND="${RDEPEND}
+ >=sys-devel/bison-1.34
+ >=sys-devel/flex-2.5
+ >=sys-apps/sed-4"
src_unpack() {
local f
@@ -34,18 +37,18 @@ src_unpack() {
src_compile() {
egamesconf \
- `use_with X x` \
- `use_with X xshogi` || die
+ $(use_with X x) \
+ $(use_with X xshogi) || die
addpredict /usr/games/lib/gnushogi/gnushogi.hsh
emake || die "emake failed"
}
src_install() {
dogamesbin gnushogi/gnushogi || die "dogamesbin failed"
- if [ `use X` ] ; then
+ if use X ; then
dogamesbin xshogi/xshogi || die "dogamesbin failed (X)"
fi
dogameslib gnushogi/gnushogi.bbk || die "dogameslib failed"
- dodoc INSTALL README NEWS CONTRIB || die "dodoc failed"
+ dodoc INSTALL README NEWS CONTRIB
prepgamesdirs
}