summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-03-06 17:21:59 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-03-06 17:21:59 +0000
commitdcb7dd0bf65c8e1c0aa42c3579820a8ebd68e775 (patch)
treee5ceeeb4a854f5a04fcfcf61cdb20f7203a188c9 /games-emulation/gngeo/gngeo-0.6.10.ebuild
parentVersion bump. (diff)
downloadhistorical-dcb7dd0bf65c8e1c0aa42c3579820a8ebd68e775.tar.gz
historical-dcb7dd0bf65c8e1c0aa42c3579820a8ebd68e775.tar.bz2
historical-dcb7dd0bf65c8e1c0aa42c3579820a8ebd68e775.zip
version bump
Package-Manager: portage-2.1_pre5-r4
Diffstat (limited to 'games-emulation/gngeo/gngeo-0.6.10.ebuild')
-rw-r--r--games-emulation/gngeo/gngeo-0.6.10.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/games-emulation/gngeo/gngeo-0.6.10.ebuild b/games-emulation/gngeo/gngeo-0.6.10.ebuild
new file mode 100644
index 000000000000..8c802aa62180
--- /dev/null
+++ b/games-emulation/gngeo/gngeo-0.6.10.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/gngeo/gngeo-0.6.10.ebuild,v 1.1 2006/03/06 17:21:59 mr_bones_ Exp $
+
+inherit flag-o-matic games
+
+DESCRIPTION="A NeoGeo emulator"
+HOMEPAGE="http://m.peponas.free.fr/gngeo/"
+SRC_URI="http://m.peponas.free.fr/gngeo/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ sys-libs/zlib
+ media-libs/sdl-image
+ >=media-libs/libsdl-1.2"
+DEPEND="${RDEPEND}
+ x86? ( >=dev-lang/nasm-0.98 )"
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS NEWS README sample_gngeorc
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "A licensed NeoGeo BIOS copy is required to run the emulator."
+ echo
+}