summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2006-09-26 18:43:45 +0000
committerTristan Heaven <tristan@gentoo.org>2006-09-26 18:43:45 +0000
commit69abbbfb1a326cf3742741010ebc6d753ef091e2 (patch)
tree9878a1216f8d845e4d035b5a34cf11edad7ec19c /games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild
parentFixed DEPEND/RDEPEND. (diff)
downloadhistorical-69abbbfb1a326cf3742741010ebc6d753ef091e2.tar.gz
historical-69abbbfb1a326cf3742741010ebc6d753ef091e2.tar.bz2
historical-69abbbfb1a326cf3742741010ebc6d753ef091e2.zip
Let portage strip binaries, bug #137832
Package-Manager: portage-2.1.2_pre1-r3
Diffstat (limited to 'games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild')
-rw-r--r--games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild11
1 files changed, 7 insertions, 4 deletions
diff --git a/games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild b/games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild
index e06f6f26ea0b..25caa50a7429 100644
--- a/games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild
+++ b/games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild,v 1.2 2005/08/07 07:36:26 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/ps2emu-usbnull/ps2emu-usbnull-0.4.ebuild,v 1.3 2006/09/26 18:43:45 nyhm Exp $
inherit games
@@ -13,7 +13,7 @@ SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-RDEPEND="=x11-libs/gtk+-1*"
+RDEPEND="=x11-libs/gtk+-1.2*"
DEPEND="${RDEPEND}
app-arch/unrar"
@@ -22,7 +22,10 @@ S=${WORKDIR}/USBnull${PV//.}
src_unpack() {
unrar x -idq "${DISTDIR}"/${A} || die
cd "${S}"
- sed -i 's:-O3 -fomit-frame-pointer:$(OPTFLAGS):' Linux/Makefile || die
+ sed -i \
+ -e 's:-O3 -fomit-frame-pointer:$(OPTFLAGS):' \
+ -e '/strip/d' \
+ Linux/Makefile || die
}
src_compile() {