summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-09-02 20:17:20 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-09-02 20:17:20 +0000
commit6371d689781ad7a4cee7af3ddfa56a451eb70e42 (patch)
tree0b20a2b2b3aa9075170f68b9e940f4937b214c9c /games-emulation
parentreconfig hook now cleans up after itself (diff)
downloadhistorical-6371d689781ad7a4cee7af3ddfa56a451eb70e42.tar.gz
historical-6371d689781ad7a4cee7af3ddfa56a451eb70e42.tar.bz2
historical-6371d689781ad7a4cee7af3ddfa56a451eb70e42.zip
Install chdman and xml2info in GAMES_LIBDIR
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/xmame/ChangeLog5
-rw-r--r--games-emulation/xmame/Manifest4
-rw-r--r--games-emulation/xmame/xmame-0.86.ebuild5
3 files changed, 9 insertions, 5 deletions
diff --git a/games-emulation/xmame/ChangeLog b/games-emulation/xmame/ChangeLog
index 3f1a945254a7..2fd8d6a4a006 100644
--- a/games-emulation/xmame/ChangeLog
+++ b/games-emulation/xmame/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-emulation/xmame
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.26 2004/09/02 19:42:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/ChangeLog,v 1.27 2004/09/02 20:17:20 mr_bones_ Exp $
+
+ 02 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.86.ebuild:
+ Install chdman and xml2info in GAMES_LIBDIR
02 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> xmame-0.86.ebuild:
turn on joystick support always for libsdl; should fix bug #62620
diff --git a/games-emulation/xmame/Manifest b/games-emulation/xmame/Manifest
index 2bb12d2ef436..e894fb475fe1 100644
--- a/games-emulation/xmame/Manifest
+++ b/games-emulation/xmame/Manifest
@@ -1,8 +1,8 @@
-MD5 ae8a5502693d72f26de6ee70ed37712f ChangeLog 6918
+MD5 2b93aa8389b10e61bb443a0077704236 ChangeLog 7039
MD5 0234d9024c471faf92bb1219242614ef metadata.xml 1566
MD5 30e8d4b0106df48fc70f99beb5608280 xmame-0.82.1.ebuild 6437
MD5 3bfc553fbd6d37187aba00e77fb80875 xmame-0.83.1.ebuild 6774
-MD5 e2199edcf0f9649ad51b09e7bbae0b81 xmame-0.86.ebuild 5843
+MD5 a087666ec2ee9473d4c2e4a26843ea2b xmame-0.86.ebuild 5868
MD5 9bbbd2de60f0c41f643674a694cd2c90 files/0.77.1-alsa-1.0.0.patch 438
MD5 13dc5b32bbff98dec74c41dd0c9b33a1 files/0.77.1-glx-fix.patch 597
MD5 93b9c4a740015eb7262b223c7b8b7bbf files/0.77.1-icc.patch 584
diff --git a/games-emulation/xmame/xmame-0.86.ebuild b/games-emulation/xmame/xmame-0.86.ebuild
index a80016b8eee7..87616cdb3b88 100644
--- a/games-emulation/xmame/xmame-0.86.ebuild
+++ b/games-emulation/xmame/xmame-0.86.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.86.ebuild,v 1.2 2004/09/02 19:42:49 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/xmame/xmame-0.86.ebuild,v 1.3 2004/09/02 20:17:20 mr_bones_ Exp $
inherit flag-o-matic gcc eutils games
@@ -179,7 +179,8 @@ src_install() {
if [ ${disp} -eq 0 ] || use X || use dga || use xv ; then
make DISPLAY_METHOD=x11 install || die "install failed (x11)"
fi
- dogamesbin chdman || die "dogamesbin chdman failed"
+ exeinto "${GAMES_LIBDIR}/${PN}"
+ doexe chdman xml2info || die "doexe failed"
dodir "${GAMES_DATADIR}/${PN}"
cp -r ctrlr "${D}/${GAMES_DATADIR}/${PN}/" || die "cp failed"