summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-10-14 15:27:19 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-10-14 15:27:19 +0000
commitb93e72b5535e00a3f6cf290a12eb373dddeadb55 (patch)
treefff3e51946f3e2c34f372e9fa117023d788e3016 /games-emulation
parentprovide a custom src_test since the default one fails. fix one pkg_postinst e... (diff)
downloadhistorical-b93e72b5535e00a3f6cf290a12eb373dddeadb55.tar.gz
historical-b93e72b5535e00a3f6cf290a12eb373dddeadb55.tar.bz2
historical-b93e72b5535e00a3f6cf290a12eb373dddeadb55.zip
version bump
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'games-emulation')
-rw-r--r--games-emulation/hatari/ChangeLog7
-rw-r--r--games-emulation/hatari/Manifest18
-rw-r--r--games-emulation/hatari/files/digest-hatari-0.801
-rw-r--r--games-emulation/hatari/hatari-0.80.ebuild61
4 files changed, 73 insertions, 14 deletions
diff --git a/games-emulation/hatari/ChangeLog b/games-emulation/hatari/ChangeLog
index 8d01311ea58c..0ad08e2b8fb9 100644
--- a/games-emulation/hatari/ChangeLog
+++ b/games-emulation/hatari/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-emulation/hatari
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.9 2005/07/08 21:31:24 lanius Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/ChangeLog,v 1.10 2005/10/14 15:27:19 mr_bones_ Exp $
+
+*hatari-0.80 (14 Oct 2005)
+
+ 14 Oct 2005; Michael Sterrett <mr_bones_@gentoo.org> +hatari-0.80.ebuild:
+ version bump
08 Jul 2005; Heinrich Wendel <lanius@gentoo.org> hatari-0.70.ebuild:
add ~amd64
diff --git a/games-emulation/hatari/Manifest b/games-emulation/hatari/Manifest
index ed4a5dae5932..5acd57bb89fd 100644
--- a/games-emulation/hatari/Manifest
+++ b/games-emulation/hatari/Manifest
@@ -1,16 +1,8 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 8443e34c834f4173195edf4257748a5e hatari-0.70.ebuild 1542
-MD5 09908f04b13581f68880f4ddb9ba1a55 hatari-0.45.ebuild 1502
-MD5 69e75a6ada176d69844bc91829cbc3ad ChangeLog 1526
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 34b25dfd0d29ad062cbdd864e7ea61f7 hatari-0.80.ebuild 1622
+MD5 09908f04b13581f68880f4ddb9ba1a55 hatari-0.45.ebuild 1502
+MD5 8443e34c834f4173195edf4257748a5e hatari-0.70.ebuild 1542
+MD5 a16489813051822fcf1eec9f2db61058 ChangeLog 1650
MD5 805ba6098c50b3ada3ee70778d225fc3 files/digest-hatari-0.45 63
+MD5 940ccc29d4a48250331028389ab3427b files/digest-hatari-0.80 63
MD5 56916d0e45717c2c29fb53390294458a files/digest-hatari-0.70 63
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.1 (GNU/Linux)
-
-iD8DBQFCzvDMevY57Fted3ERAlQdAJ9ooCH0dYPDASKtC2PEjwDukExkMACfZNvG
-SnbJatf1Xu842PQKyd4h4v4=
-=/5E/
------END PGP SIGNATURE-----
diff --git a/games-emulation/hatari/files/digest-hatari-0.80 b/games-emulation/hatari/files/digest-hatari-0.80
new file mode 100644
index 000000000000..881a3ae03c1d
--- /dev/null
+++ b/games-emulation/hatari/files/digest-hatari-0.80
@@ -0,0 +1 @@
+MD5 01d342566d69a4721b61ad5c912174ec hatari-0.80.tar.gz 597945
diff --git a/games-emulation/hatari/hatari-0.80.ebuild b/games-emulation/hatari/hatari-0.80.ebuild
new file mode 100644
index 000000000000..b3bd2ca6df4f
--- /dev/null
+++ b/games-emulation/hatari/hatari-0.80.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/hatari/hatari-0.80.ebuild,v 1.1 2005/10/14 15:27:19 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Atari ST emulator"
+HOMEPAGE="http://hatari.sourceforge.net/"
+SRC_URI="mirror://sourceforge/hatari/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}
+ games-emulation/emutos"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e '/^CC/d' \
+ -e "/^CFLAGS/ s:=.*:=${CFLAGS}:" \
+ -e "/^DATADIR/ s:=.*:= ${GAMES_DATADIR}/${PN}:" Makefile.cnf \
+ || die "sed Makefile.cnf failed"
+}
+
+src_compile() {
+ # broken deps in the makefiles
+ emake -C src/uae-cpu gencpu || die "emake failed"
+ emake -C src || die "emake failed"
+}
+
+src_install() {
+ dogamesbin "${S}/src/hatari" || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins src/gui-sdl/font5x8.bmp src/gui-sdl/font10x16.bmp \
+ || die "doins failed"
+ dodoc readme.txt doc/*.txt
+ dohtml -r doc/
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ echo
+ einfo "You need a TOS ROM to run hatari. EmuTOS, a free TOS implementation,"
+ einfo "has been installed in /usr/games/lib/ with a .img extension (there"
+ einfo "are several from which to choose)."
+ echo
+ einfo "Another option is to go to http://www.atari.st/ and get a real TOS:"
+ einfo " http://www.atari.st/"
+ echo
+ einfo "The first time you run hatari, you should configure it to find the"
+ einfo "TOS you prefer to use. Be sure to save your settings."
+ echo
+}