summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Hüttel <dilfridge@gentoo.org>2012-01-01 12:22:57 +0000
committerAndreas Hüttel <dilfridge@gentoo.org>2012-01-01 12:22:57 +0000
commit23cb191db77155ab213d30e3b2be059ad7fc7bd9 (patch)
treed5b5648d0ddf0420b8726af8c4a735a1cd8b6dd4 /games-mud/kmuddy/files
parentmedia-gfx/imageworsener: 0.9.6 (diff)
downloadhistorical-23cb191db77155ab213d30e3b2be059ad7fc7bd9.tar.gz
historical-23cb191db77155ab213d30e3b2be059ad7fc7bd9.tar.bz2
historical-23cb191db77155ab213d30e3b2be059ad7fc7bd9.zip
Fix underlinking and tempnam failure so pkgmask can be lifted again; bug 371451
Package-Manager: portage-2.1.10.41/cvs/Linux x86_64
Diffstat (limited to 'games-mud/kmuddy/files')
-rw-r--r--games-mud/kmuddy/files/kmuddy-1.0.1-tempnam.patch29
-rw-r--r--games-mud/kmuddy/files/kmuddy-1.0.1-underlinking.patch24
2 files changed, 53 insertions, 0 deletions
diff --git a/games-mud/kmuddy/files/kmuddy-1.0.1-tempnam.patch b/games-mud/kmuddy/files/kmuddy-1.0.1-tempnam.patch
new file mode 100644
index 000000000000..c4838aa4b89d
--- /dev/null
+++ b/games-mud/kmuddy/files/kmuddy-1.0.1-tempnam.patch
@@ -0,0 +1,29 @@
+--- plugins/scripting/cunixsocket.cpp
++++ plugins/scripting/cunixsocket.cpp
+@@ -40,12 +40,21 @@
+ varlist = 0;
+ connected = false;
+
+- //first of all, we need a file name
+- char *fname = tempnam ("/tmp", "km");
+- if (fname != 0) //only if it didn't fail
++ //22 = strlen(form) + strlen(/sock) + 1
++ char form[]="/tmp/kmuddyXXXXXX", *dirname, sockname[22];
++ dirname = mkdtemp(form);
++
++ if (dirname != NULL) //only if it didn't fail
+ {
+- name = fname;
+- free (fname);
++
++ strcpy(sockname, dirname);
++ strcat(dirname, "/sock");
++
++ name = dirname;
++ free (form);
++ free (dirname);
++ free (sockname);
++
+ //now that we have the name, we create a socket and set some parameters
+ id = socket (PF_UNIX, SOCK_STREAM, 0);
+ sa.sun_family = AF_UNIX;
diff --git a/games-mud/kmuddy/files/kmuddy-1.0.1-underlinking.patch b/games-mud/kmuddy/files/kmuddy-1.0.1-underlinking.patch
new file mode 100644
index 000000000000..18c68c4742df
--- /dev/null
+++ b/games-mud/kmuddy/files/kmuddy-1.0.1-underlinking.patch
@@ -0,0 +1,24 @@
+diff -ruN kmuddy-1.0.1.orig/kmuddy/CMakeLists.txt kmuddy-1.0.1/kmuddy/CMakeLists.txt
+--- kmuddy-1.0.1.orig/kmuddy/CMakeLists.txt 2009-03-14 13:24:55.000000000 +0100
++++ kmuddy-1.0.1/kmuddy/CMakeLists.txt 2012-01-01 11:40:31.000000000 +0100
+@@ -49,7 +49,7 @@
+
+ kde4_add_executable(kmuddy ${kmuddy_SRCS})
+
+-set (KMUDDY_LIBRARIES kmuddycore dialogs ${KDE4_KDECORE_LIBS} ${KDE4_KPARTS_LIBS} ${KDE4_KUTILS_LIBS} ${KDE4_KDEUI_LIBS} ${KDE4_PHONON_LIBS} ${KDE4_KDE3SUPPORT_LIBS})
++set (KMUDDY_LIBRARIES kmuddycore dialogs ${KDE4_KDECORE_LIBS} ${KDE4_KPARTS_LIBS} ${KDE4_KUTILS_LIBS} ${KDE4_KDEUI_LIBS} ${KDE4_PHONON_LIBS} ${KDE4_KDE3SUPPORT_LIBS} z)
+
+ if (MXP_FOUND)
+ set (KMUDDY_LIBRARIES ${KMUDDY_LIBRARIES} ${MXP_LIBRARIES})
+diff -ruN kmuddy-1.0.1.orig/plugins/mapper/plugins/speedwalk/CMakeLists.txt kmuddy-1.0.1/plugins/mapper/plugins/speedwalk/CMakeLists.txt
+--- kmuddy-1.0.1.orig/plugins/mapper/plugins/speedwalk/CMakeLists.txt 2009-01-10 12:40:59.000000000 +0100
++++ kmuddy-1.0.1/plugins/mapper/plugins/speedwalk/CMakeLists.txt 2012-01-01 13:15:35.000000000 +0100
+@@ -17,7 +17,7 @@
+
+ kde4_add_plugin(kmuddymapper_speedwalk WITH_PREFIX ${kmuddymapper_speedwalk_PART_SRCS})
+
+-target_link_libraries(kmuddymapper_speedwalk ${KDE4_KDECORE_LIBS} ${KDE4_KPARTS_LIBS} ${KDE4_KDE3SUPPORT_LIBS} kmuddymapper )
++target_link_libraries(kmuddymapper_speedwalk kmuddymapper kmuddycore ${KDE4_KDECORE_LIBS} ${KDE4_KPARTS_LIBS} ${KDE4_KDE3SUPPORT_LIBS} )
+
+ install(TARGETS kmuddymapper_speedwalk DESTINATION ${PLUGIN_INSTALL_DIR} )
+