summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <tristan@gentoo.org>2009-05-23 20:25:42 +0000
committerTristan Heaven <tristan@gentoo.org>2009-05-23 20:25:42 +0000
commit3019c61a31edc60d91178a3beb1131cbe2b0679b (patch)
tree62dec126c1084c5c2d6d3050fdf92d753f999e2d /games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild
parentBump to 2.26.2. Make configure more portage. Update translations. (diff)
downloadhistorical-3019c61a31edc60d91178a3beb1131cbe2b0679b.tar.gz
historical-3019c61a31edc60d91178a3beb1131cbe2b0679b.tar.bz2
historical-3019c61a31edc60d91178a3beb1131cbe2b0679b.zip
Patch from Fedora to fix blitting error with pygame-1.8, bug #263854
Package-Manager: portage-2.2_rc33/cvs/Linux i686
Diffstat (limited to 'games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild')
-rw-r--r--games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild b/games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..5ff7df929f21
--- /dev/null
+++ b/games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/monsterz/monsterz-0.7.1-r2.ebuild,v 1.1 2009/05/23 20:25:42 nyhm Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="a little puzzle game, similar to the famous Bejeweled or Zookeeper"
+HOMEPAGE="http://sam.zoy.org/projects/monsterz/"
+SRC_URI="http://sam.zoy.org/projects/monsterz/${P}.tar.gz"
+
+LICENSE="WTFPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE=""
+
+DEPEND="dev-python/pygame
+ media-libs/sdl-image[png]
+ media-libs/sdl-mixer[mikmod]"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-blit.patch
+ sed -i \
+ -e "s:GENTOO_DATADIR:${GAMES_DATADIR}/${PN}:" \
+ monsterz.py || die "sed failed"
+ rm -f Makefile
+}
+
+src_install() {
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r graphics sound || die "doins failed"
+ newgamesbin monsterz.py ${PN} || die "newgamesbin failed"
+ newicon graphics/icon.png ${PN}.png
+ make_desktop_entry ${PN} Monsterz
+ dodoc README AUTHORS TODO
+ prepgamesdirs
+}