summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-10-19 03:36:14 +0000
committerMike Frysinger <vapier@gentoo.org>2003-10-19 03:36:14 +0000
commit293a3156f803f1ce6e9601d9e786c3c46244e1a0 (patch)
treeea2e8ff5f764992b8ba10a6108298deecf4236e8 /games-rpg/daimonin-client
parentNew PATCH_VER 2.1.19. Pulling 9132_all_4.3.0-Mesa-SSE-fixes-from-MesaCVS.patc... (diff)
downloadhistorical-293a3156f803f1ce6e9601d9e786c3c46244e1a0.tar.gz
historical-293a3156f803f1ce6e9601d9e786c3c46244e1a0.tar.bz2
historical-293a3156f803f1ce6e9601d9e786c3c46244e1a0.zip
initial ebuild
Diffstat (limited to 'games-rpg/daimonin-client')
-rw-r--r--games-rpg/daimonin-client/ChangeLog8
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.95b.ebuild42
-rw-r--r--games-rpg/daimonin-client/files/0.95b-gcc3.patch42
-rw-r--r--games-rpg/daimonin-client/files/0.95b-gentoo-paths.patch104
-rw-r--r--games-rpg/daimonin-client/files/digest-daimonin-client-0.95b1
5 files changed, 197 insertions, 0 deletions
diff --git a/games-rpg/daimonin-client/ChangeLog b/games-rpg/daimonin-client/ChangeLog
new file mode 100644
index 000000000000..22daba57d004
--- /dev/null
+++ b/games-rpg/daimonin-client/ChangeLog
@@ -0,0 +1,8 @@
+# ChangeLog for games-rpg/daimonin-client
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.1 2003/10/19 03:36:07 vapier Exp $
+
+*daimonin-client-0.95b (18 Oct 2003)
+
+ 18 Oct 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by me.
diff --git a/games-rpg/daimonin-client/daimonin-client-0.95b.ebuild b/games-rpg/daimonin-client/daimonin-client-0.95b.ebuild
new file mode 100644
index 000000000000..6f988020ee16
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.95b.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/daimonin-client-0.95b.ebuild,v 1.1 2003/10/19 03:36:07 vapier Exp $
+
+inherit games eutils flag-o-matic
+
+DESCRIPTION="MMORPG with 2D isometric tiles grafik, true color and alpha blending effects"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/daimonin/dm_client_${PV/0.}_src.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image
+ virtual/x11"
+
+S=${WORKDIR}/daimonin/client
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch ${FILESDIR}/${PV}-gentoo-paths.patch
+ epatch ${FILESDIR}/${PV}-gcc3.patch
+}
+
+src_compile() {
+ cd make/linux
+ append-flags -DGENTOO_DATADIR="'\"${GAMES_DATADIR}/${PN}\"'"
+ emake EXTRA_CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ dogamesbin src/daimonin
+ dodir ${GAMES_DATADIR}/${PN}
+ cp -r bitmaps icons media sfx cache ${D}/${GAMES_DATADIR}/${PN}/
+ insinto ${GAMES_DATADIR}/${PN}
+ doins *.dat
+ prepgamesdirs
+}
diff --git a/games-rpg/daimonin-client/files/0.95b-gcc3.patch b/games-rpg/daimonin-client/files/0.95b-gcc3.patch
new file mode 100644
index 000000000000..eac3dd30aed1
--- /dev/null
+++ b/games-rpg/daimonin-client/files/0.95b-gcc3.patch
@@ -0,0 +1,42 @@
+--- src/socket.c.orig 2003-10-18 22:14:41.722083520 -0400
++++ src/socket.c 2003-10-18 22:15:26.096337608 -0400
+@@ -370,8 +370,7 @@
+ *socket_temp = SOCKET_NO;
+ return FALSE;
+ }
+- csocket.inbuf.buf=(unsigned char *)_malloc(MAXSOCKBUF,"SOCKET_OpenSocket():
+-MAXSOCKBUF");
++ csocket.inbuf.buf=(unsigned char *)_malloc(MAXSOCKBUF,"SOCKET_OpenSocket(): MAXSOCKBUF");
+ csocket.inbuf.len=0;
+ insock.sin_family = AF_INET;
+ insock.sin_port = htons((unsigned short)port);
+@@ -410,8 +409,7 @@
+ if(setsockopt(*socket_temp,SOL_SOCKET,SO_RCVBUF, (char*)&newbufsize,
+ sizeof(&newbufsize)))
+ {
+- LOG(1,"InitConnection: setsockopt unable to set output buf size to
+-%d\n", newbufsize);
++ LOG(1,"InitConnection: setsockopt unable to set output buf size to %d\n", newbufsize);
+ setsockopt(*socket_temp,SOL_SOCKET,SO_RCVBUF, (char*)&oldbufsize,
+ sizeof(&oldbufsize));
+ }
+@@ -447,10 +445,8 @@
+ int stat,temp;
+ char *ptr, *buf;
+
+- ptr = (char*)_malloc(MAX_METASTRING_BUFFER,"read_metaserver_data(): metastring
+-buffer1");
+- buf = (char*)_malloc(MAX_METASTRING_BUFFER,"read_metaserver_data(): metastring
+-buffer2");
++ ptr = (char*)_malloc(MAX_METASTRING_BUFFER,"read_metaserver_data(): metastring buffer1");
++ buf = (char*)_malloc(MAX_METASTRING_BUFFER,"read_metaserver_data(): metastring buffer2");
+ temp=0;
+ for(;;)
+ {
+@@ -603,4 +599,4 @@
+ }
+ return 0;
+ }
+-#endif
+\ No newline at end of file
++#endif
diff --git a/games-rpg/daimonin-client/files/0.95b-gentoo-paths.patch b/games-rpg/daimonin-client/files/0.95b-gentoo-paths.patch
new file mode 100644
index 000000000000..e8af9b311d20
--- /dev/null
+++ b/games-rpg/daimonin-client/files/0.95b-gentoo-paths.patch
@@ -0,0 +1,104 @@
+--- src/wrapper.c.orig 2003-10-18 22:20:38.154897496 -0400
++++ src/wrapper.c 2003-10-18 22:21:11.628808688 -0400
+@@ -84,28 +84,28 @@
+ char * GetBitmapDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./bitmaps/");
++ return(GENTOO_DATADIR "/bitmaps/");
+ #endif
+ }
+
+ char * GetIconDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./icons/");
++ return(GENTOO_DATADIR "/icons/");
+ #endif
+ }
+
+ char * GetSfxDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./sfx/");
++ return(GENTOO_DATADIR "/sfx/");
+ #endif
+ }
+
+ char * GetCacheDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./cache/");
++ return(GENTOO_DATADIR "/cache/");
+ #endif
+ }
+
+@@ -113,7 +113,7 @@
+ char * GetMediaDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./media/");
++ return(GENTOO_DATADIR "/media/");
+ #endif
+ }
+
+--- src/menu.c.orig 2003-10-18 22:55:47.836177192 -0400
++++ src/menu.c 2003-10-18 22:56:29.063909624 -0400
+@@ -884,7 +885,7 @@
+ FILE *stream;
+ char line[255], name[255], d1[255], d2[255], d3[255], d4[255], icon[128];
+
+- if( (stream = fopen("./spells.dat", "r" )) != NULL )
++ if( (stream = fopen(GENTOO_DATADIR "/spells.dat", "r" )) != NULL )
+ {
+ for(i=0;;i++)
+ {
+@@ -949,7 +950,7 @@
+ FILE *stream;
+ char line[255], name[255], d1[255], d2[255], d3[255], d4[255], icon[128];
+
+- if( (stream = fopen("./skills.dat", "r" )) != NULL )
++ if( (stream = fopen(GENTOO_DATADIR "/skills.dat", "r" )) != NULL )
+ {
+ for(i=0;;i++)
+ {
+--- src/include/config.h.orig 2003-10-18 22:49:31.166439696 -0400
++++ src/include/config.h 2003-10-18 22:55:37.103808760 -0400
+@@ -29,11 +29,13 @@
+ #define VERSION_CS 991013
+ #define VERSION_SC 991013
+
+-#define KEYBIND_FILE "./keys.dat"
+-#define OPTION_FILE "./options.dat"
+-#define ARCHDEF_FILE "./archdef.dat"
++#include "userfile.h"
+
+-#define LOG_FILE "./client.log"
++#define KEYBIND_FILE user_file("keys.dat")
++#define OPTION_FILE user_file("options.dat")
++#define ARCHDEF_FILE GENTOO_DATADIR "/archdef.dat"
++
++#define LOG_FILE user_file("client.log")
+
+ #define CLIENT_ICON_NAME "icon.png"
+
+--- src/include/userfile.h 1969-12-31 19:00:00.000000000 -0500
++++ src/include/userfile.h 2003-10-18 22:55:26.081484408 -0400
+@@ -0,0 +1,17 @@
++#include <stdio.h> /* snprintf */
++#include <stdlib.h> /* getenv */
++#include <sys/stat.h> /* mkdir */
++#include <sys/types.h> /* mkdir */
++#include <unistd.h> /* lstat */
++static char *user_file(char *filename)
++{
++ #define MAX_PATH 1024
++ static char pathname[MAX_PATH];
++ static struct stat mystat;
++ snprintf(pathname, MAX_PATH, "%s/.daimonin", getenv("HOME"));
++ mkdir(pathname, 0700);
++ snprintf(pathname, MAX_PATH, "%s/.daimonin/%s", getenv("HOME"), filename);
++ if (lstat(pathname, &mystat))
++ sprintf(pathname, "%s/%s", GENTOO_DATADIR, filename);
++ return pathname;
++}
diff --git a/games-rpg/daimonin-client/files/digest-daimonin-client-0.95b b/games-rpg/daimonin-client/files/digest-daimonin-client-0.95b
new file mode 100644
index 000000000000..3e4d8a2437f4
--- /dev/null
+++ b/games-rpg/daimonin-client/files/digest-daimonin-client-0.95b
@@ -0,0 +1 @@
+MD5 fcb2e98faa1acbaaeaa56d5b1f3f9b36 dm_client_95b_src.zip 12831487