summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-02-26 21:16:18 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-02-26 21:16:18 +0000
commit635bfda708761227321a063b16d3cb296632b85b (patch)
tree784f340b2937d4da0750d3ddda20136db953f1fe /games-strategy/uqm
parentVersion bumped (diff)
downloadhistorical-635bfda708761227321a063b16d3cb296632b85b.tar.gz
historical-635bfda708761227321a063b16d3cb296632b85b.tar.bz2
historical-635bfda708761227321a063b16d3cb296632b85b.zip
fix up data directory location (/usr/games/share -> /usr/share/games)
Diffstat (limited to 'games-strategy/uqm')
-rw-r--r--games-strategy/uqm/ChangeLog9
-rw-r--r--games-strategy/uqm/Manifest4
-rw-r--r--games-strategy/uqm/files/digest-uqm-0.3-r14
-rw-r--r--games-strategy/uqm/uqm-0.3-r1.ebuild93
4 files changed, 107 insertions, 3 deletions
diff --git a/games-strategy/uqm/ChangeLog b/games-strategy/uqm/ChangeLog
index 008a591baa09..2a205dc9c747 100644
--- a/games-strategy/uqm/ChangeLog
+++ b/games-strategy/uqm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-strategy/uqm
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/ChangeLog,v 1.5 2003/09/17 06:24:14 msterret Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/ChangeLog,v 1.6 2004/02/26 21:16:18 mr_bones_ Exp $
+
+*uqm-0.3-r1 (26 Feb 2004)
+
+ 26 Feb 2004; Michael Sterrett <mr_bones_@gentoo.org> uqm-0.3-r1.ebuild:
+ fix up data directory location (/usr/games/share -> /usr/share/games)
16 Sep 2003; Michael Sterrett <msterret@gentoo.org> uqm-0.3.ebuild:
Mark stable
diff --git a/games-strategy/uqm/Manifest b/games-strategy/uqm/Manifest
index 591ee5709725..2ce6fc473fb0 100644
--- a/games-strategy/uqm/Manifest
+++ b/games-strategy/uqm/Manifest
@@ -1,4 +1,6 @@
-MD5 8905da6553d835f4060ca3cc7dfece05 ChangeLog 789
+MD5 8b3f92568b4244b5db5a8ef24761272f ChangeLog 964
MD5 fffadd053673e473f6456c2b2ed93739 uqm-0.3.ebuild 2070
MD5 a30c9d4ce8f9629d6d7323eaab258343 metadata.xml 241
+MD5 2cfc4d22fd704d8ff1502ee0f811f4f9 uqm-0.3-r1.ebuild 2463
+MD5 352d8c8a28dfc130e621263c405143f4 files/digest-uqm-0.3-r1 261
MD5 352d8c8a28dfc130e621263c405143f4 files/digest-uqm-0.3 261
diff --git a/games-strategy/uqm/files/digest-uqm-0.3-r1 b/games-strategy/uqm/files/digest-uqm-0.3-r1
new file mode 100644
index 000000000000..c9850829de07
--- /dev/null
+++ b/games-strategy/uqm/files/digest-uqm-0.3-r1
@@ -0,0 +1,4 @@
+MD5 9073251b0d96393441f0b40016010576 uqm-0.3-3domusic.zip 18980505
+MD5 b17bb7b54df03b2d0ae3a23b91382b27 uqm-0.3-content.zip 12554418
+MD5 9a44f0037d05c453b9e570b88b12595f uqm-0.3-voice.zip 114985054
+MD5 6abcdc3caf7efd3bd978332743ee7568 uqm-0.3-source.tgz 906653
diff --git a/games-strategy/uqm/uqm-0.3-r1.ebuild b/games-strategy/uqm/uqm-0.3-r1.ebuild
new file mode 100644
index 000000000000..aa91ab4531c7
--- /dev/null
+++ b/games-strategy/uqm/uqm-0.3-r1.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/uqm/uqm-0.3-r1.ebuild,v 1.1 2004/02/26 21:16:18 mr_bones_ Exp $
+
+inherit games
+
+DESCRIPTION="Port of Star Control 2"
+HOMEPAGE="http://sc2.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sc2/${P}-3domusic.zip
+ mirror://sourceforge/sc2/${P}-content.zip
+ mirror://sourceforge/sc2/${P}-voice.zip
+ mirror://sourceforge/sc2/${P}-source.tgz"
+
+KEYWORDS="x86 ~ppc"
+LICENSE="GPL-2"
+IUSE="opengl"
+SLOT="0"
+
+RDEPEND="virtual/glibc
+ virtual/x11
+ media-libs/libvorbis
+ media-libs/jpeg
+ media-libs/libpng
+ >=media-libs/libsdl-1.2.5
+ >=media-libs/sdl-image-1.2.3
+ media-libs/libogg
+ media-libs/libvorbis
+ sys-libs/zlib"
+DEPEND="${RDEPEND}
+ >=sys-apps/sed-4
+ sys-apps/coreutils
+ app-arch/unzip"
+
+src_unpack() {
+ local myopengl
+
+ unpack ${P}-source.tgz
+ cd ${S}
+
+ use opengl \
+ && myopengl=opengl \
+ || myopengl=pure
+
+ cat <<-EOF > config.state
+ CHOICE_debug_VALUE='nodebug'
+ CHOICE_graphics_VALUE='${myopengl}'
+ CHOICE_sound_VALUE='mixsdl'
+ INPUT_install_prefix_VALUE='${GAMES_PREFIX}'
+ INPUT_install_bindir_VALUE='\$prefix/bin'
+ INPUT_install_libdir_VALUE='\$prefix/lib'
+ EOF
+
+ # Take out the read so we can be non-interactive.
+ sed -i \
+ -e '/read CHOICE/d' build/unix/menu_functions || \
+ die "sed menu_functions failed"
+
+ # support the user's CFLAGS.
+ sed -i \
+ -e "s/-O3/${CFLAGS}/" build/unix/build.config || \
+ die "sed build.config failed"
+ cat > ${T}/uqm <<-EOF
+ #!/bin/sh
+ # Wrapper script for starting The Ur-Quan Masters
+ exec /usr/games/lib/uqm/uqm --contentdir="${GAMES_DATADIR}/${PN}/content" "\$@"
+EOF
+}
+
+src_compile() {
+ ./build.sh uqm || die
+}
+
+src_install() {
+ # Using the included install scripts seems quite painful.
+ # This manual install is totally fragile but maybe they'll
+ # use a sane build system.
+ dogamesbin "${T}/uqm" || die "dogamesbin failed"
+ exeinto "${GAMES_LIBDIR}/${PN}"
+ doexe uqm || die "doexe failed"
+ keepdir "${GAMES_DATADIR}/${PN}/content/packages/addons"
+ dodir "${GAMES_DATADIR}/${PN}/content/packages/content"
+ cp content/version "${D}${GAMES_DATADIR}/${PN}/content" || die "cp failed"
+ cp ${DISTDIR}/${P}-{3domusic,content,voice}.zip \
+ "${D}${GAMES_DATADIR}/${PN}/content/packages" \
+ || die "cp media archives failed"
+
+ dodoc AUTHORS ChangeLog Contributing README TODO WhatsNew \
+ doc/users/manual.txt
+ docinto devel
+ dodoc doc/devel/*
+
+ prepgamesdirs
+}