summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2005-12-09 20:18:38 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2005-12-09 20:18:38 +0000
commit695748293767253548c992485159e80821388ae0 (patch)
treeccda0fb8145a78a0e239ae0d5317dc7e49aa7770 /games-util/loki_patch
parentChange argument name to --with-top-fontdir for consistency with upstream. (diff)
downloadhistorical-695748293767253548c992485159e80821388ae0.tar.gz
historical-695748293767253548c992485159e80821388ae0.tar.bz2
historical-695748293767253548c992485159e80821388ae0.zip
Version bumped for gcc 4.0 compatibility and closing bug #114920.
Package-Manager: portage-2.0.53
Diffstat (limited to 'games-util/loki_patch')
-rw-r--r--games-util/loki_patch/ChangeLog8
-rw-r--r--games-util/loki_patch/Manifest8
-rw-r--r--games-util/loki_patch/files/digest-loki_patch-200512091
-rw-r--r--games-util/loki_patch/loki_patch-20051209.ebuild35
4 files changed, 48 insertions, 4 deletions
diff --git a/games-util/loki_patch/ChangeLog b/games-util/loki_patch/ChangeLog
index 44a1695af79f..aeb4de2c9443 100644
--- a/games-util/loki_patch/ChangeLog
+++ b/games-util/loki_patch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-util/loki_patch
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/ChangeLog,v 1.5 2005/04/11 12:34:17 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/ChangeLog,v 1.6 2005/12/09 20:18:38 wolf31o2 Exp $
+
+*loki_patch-20051209 (09 Dec 2005)
+
+ 09 Dec 2005; Chris Gianelloni <wolf31o2@gentoo.org>
+ +loki_patch-20051209.ebuild:
+ Version bumped for gcc 4.0 compatibility and closing bug #114920.
11 Apr 2005; Chris Gianelloni <wolf31o2@gentoo.org>
-loki_patch-20040916.ebuild:
diff --git a/games-util/loki_patch/Manifest b/games-util/loki_patch/Manifest
index 18ca28014643..ff4d134ccd2f 100644
--- a/games-util/loki_patch/Manifest
+++ b/games-util/loki_patch/Manifest
@@ -1,5 +1,7 @@
+MD5 65d065438ee47a69b3f897a53590b4cb ChangeLog 1323
+MD5 0cd086d2e6b2df8cfe7b41fbf0a9f20e files/digest-loki_patch-20050324 72
+MD5 c4debd478b2666f20fc737fddfdd4bf3 files/digest-loki_patch-20051209 71
+MD5 6db02d05d799f5f6eed6dd15cc91869a files/loki_patch-20050324-amd64.patch 398
MD5 57974546ccc86579fcc8116adcbae935 loki_patch-20050324.ebuild 1008
-MD5 702443fb74876f8aa7a1dd4a86ceae0e ChangeLog 1133
+MD5 17a36ce9dd3e888551893b9efcd0c57c loki_patch-20051209.ebuild 942
MD5 11a7e1491b1ac042ac7216b26b4ad1fb metadata.xml 254
-MD5 6db02d05d799f5f6eed6dd15cc91869a files/loki_patch-20050324-amd64.patch 398
-MD5 0cd086d2e6b2df8cfe7b41fbf0a9f20e files/digest-loki_patch-20050324 72
diff --git a/games-util/loki_patch/files/digest-loki_patch-20051209 b/games-util/loki_patch/files/digest-loki_patch-20051209
new file mode 100644
index 000000000000..4a27476eff5e
--- /dev/null
+++ b/games-util/loki_patch/files/digest-loki_patch-20051209
@@ -0,0 +1 @@
+MD5 abb946fd74623db6d84177faf68ac8f7 loki_patch-20051209.tar.bz2 68250
diff --git a/games-util/loki_patch/loki_patch-20051209.ebuild b/games-util/loki_patch/loki_patch-20051209.ebuild
new file mode 100644
index 000000000000..fcfa756943a6
--- /dev/null
+++ b/games-util/loki_patch/loki_patch-20051209.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-util/loki_patch/loki_patch-20051209.ebuild,v 1.1 2005/12/09 20:18:38 wolf31o2 Exp $
+
+inherit eutils
+
+DESCRIPTION="Loki Software binary patch tool"
+HOMEPAGE="http://www.icculus.org/loki_setup/"
+SRC_URI="http://dev.gentoo.org/~wolf31o2/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="dev-util/xdelta
+ dev-libs/libxml"
+RDEPEND="games-util/loki_setupdb"
+
+src_compile() {
+ ./autogen.sh || die "autogen failed."
+ econf \
+ --with-setupdb=/usr/share/loki_setupdb \
+ || die "econf failed."
+ sed -i \
+ -e 's/\.\.\/loki_setupdb/\/usr\/share\/loki_setupdb/' \
+ -e 's/-I$(SETUPDB)/-I$(SETUPDB)\/include/' \
+ Makefile
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin loki_patch make_patch || die "doexe failed"
+ dodoc CHANGES NOTES README TODO
+}