summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn N. Laliberte <allanonjl@gentoo.org>2006-07-03 16:15:16 +0000
committerJohn N. Laliberte <allanonjl@gentoo.org>2006-07-03 16:15:16 +0000
commitddf4f01519b007b7313268e68ef0ef9d8895906c (patch)
tree74f2dca333bcc136a14873386b8e0aaa605606ab /gnome-base
parentfixes bug #128592 (diff)
downloadhistorical-ddf4f01519b007b7313268e68ef0ef9d8895906c.tar.gz
historical-ddf4f01519b007b7313268e68ef0ef9d8895906c.tar.bz2
historical-ddf4f01519b007b7313268e68ef0ef9d8895906c.zip
remove nsplugin useflag and disable mozilla plugin since its present by default in new firefox.
Package-Manager: portage-2.1.1_pre2-r2
Diffstat (limited to 'gnome-base')
-rw-r--r--gnome-base/librsvg/ChangeLog9
-rw-r--r--gnome-base/librsvg/files/digest-librsvg-2.12.7-r13
-rw-r--r--gnome-base/librsvg/librsvg-2.12.7-r1.ebuild76
3 files changed, 87 insertions, 1 deletions
diff --git a/gnome-base/librsvg/ChangeLog b/gnome-base/librsvg/ChangeLog
index 868a2104e546..9ad695c2072a 100644
--- a/gnome-base/librsvg/ChangeLog
+++ b/gnome-base/librsvg/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-base/librsvg
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.105 2006/06/30 20:45:03 dang Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/ChangeLog,v 1.106 2006/07/03 16:15:16 allanonjl Exp $
+
+*librsvg-2.12.7-r1 (03 Jul 2006)
+
+ 03 Jul 2006; John N. Laliberte <allanonjl@gentoo.org>
+ -librsvg-2.12.7.ebuild, +librsvg-2.12.7-r1.ebuild, -librsvg-2.14.3.ebuild:
+ remove nsplugin useflag and disable mozilla plugin since its present by
+ default in new firefox.
*librsvg-2.14.4 (30 Jun 2006)
diff --git a/gnome-base/librsvg/files/digest-librsvg-2.12.7-r1 b/gnome-base/librsvg/files/digest-librsvg-2.12.7-r1
new file mode 100644
index 000000000000..959ec07405bb
--- /dev/null
+++ b/gnome-base/librsvg/files/digest-librsvg-2.12.7-r1
@@ -0,0 +1,3 @@
+MD5 2113f01fbf228f3f8fc17c49966143fe librsvg-2.12.7.tar.bz2 396901
+RMD160 b7a1e61a61d1ebf595478e0bb904774d38fe92f6 librsvg-2.12.7.tar.bz2 396901
+SHA256 b2b351675547c9d4a33b8dd6d51063ce024bcdc834ff057bcb5d1c62ab0ed781 librsvg-2.12.7.tar.bz2 396901
diff --git a/gnome-base/librsvg/librsvg-2.12.7-r1.ebuild b/gnome-base/librsvg/librsvg-2.12.7-r1.ebuild
new file mode 100644
index 000000000000..0ea362237cba
--- /dev/null
+++ b/gnome-base/librsvg/librsvg-2.12.7-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-base/librsvg/librsvg-2.12.7-r1.ebuild,v 1.1 2006/07/03 16:15:16 allanonjl Exp $
+
+inherit eutils multilib gnome2
+
+DESCRIPTION="Scalable Vector Graphics (SVG) rendering library"
+HOMEPAGE="http://librsvg.sourceforge.net/"
+
+LICENSE="LGPL-2"
+SLOT="2"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+IUSE="doc gnome zlib"
+
+RDEPEND=">=media-libs/fontconfig-1.0.1
+ >=x11-libs/gtk+-2
+ >=dev-libs/glib-2
+ >=media-libs/libart_lgpl-2.3.10
+ >=dev-libs/libxml2-2.4.7
+ >=x11-libs/pango-1.2
+ >=dev-libs/popt-1.5
+ media-libs/freetype
+ >=dev-libs/libcroco-0.6
+ zlib? ( >=gnome-extra/libgsf-1.6 )
+ gnome? ( >=gnome-base/gnome-vfs-2 )"
+# libgnomeprint dependencies are not necessary
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+DOCS="AUTHORS ChangeLog NEWS README TODO"
+
+
+set_gtk_confdir() {
+ # An arch specific config directory is used on multilib systems
+ has_multilib_profile && GTK2_CONFDIR="/etc/gtk-2.0/${CHOST}"
+ GTK2_CONFDIR=${GTK2_CONFDIR:=/etc/gtk-2.0}
+}
+
+pkg_setup() {
+ # FIXME : USEify croco support (?)
+ G2CONF="--with-croco \
+ --enable-pixbuf-loader \
+ --enable-gtk-theme \
+ --disable-mozilla-plugin \
+ $(use_enable gnome gnome-vfs) \
+ $(use_with zlib svgz)"
+}
+
+src_unpack() {
+ unpack "${A}"
+ cd "${S}"
+
+ # Provide gecko toolkit autodetection and --with-mozilla switch.
+ epatch ${FILESDIR}/${PN}-2.12.6-plugin_checks.patch
+
+ autoconf || die "autoconf failed"
+}
+
+src_install() {
+ gnome2_src_install plugindir=/usr/$(get_libdir)/nsbrowser/plugins/
+
+ # remove gdk-pixbuf loaders (#47766)
+ rm -fr ${D}/etc
+}
+
+pkg_postinst() {
+ set_gtk_confdir
+ gdk-pixbuf-query-loaders > ${GTK2_CONFDIR}/gdk-pixbuf.loaders
+}
+
+pkg_postrm() {
+ set_gtk_confdir
+ gdk-pixbuf-query-loaders > ${GTK2_CONFDIR}/gdk-pixbuf.loaders
+}