summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2006-11-06 13:54:52 +0000
committerMart Raudsepp <leio@gentoo.org>2006-11-06 13:54:52 +0000
commit3746c33cde8ed6871e3f4992dc4810a2b47f0bcd (patch)
treeb2d36fa935aee5ed974a330e54a3b5657321e13c /gnome-extra/gcalctool/gcalctool-5.8.25.ebuild
parentupdate the check for the qt4 bindings based on comments from bug #150888 (diff)
downloadhistorical-3746c33cde8ed6871e3f4992dc4810a2b47f0bcd.tar.gz
historical-3746c33cde8ed6871e3f4992dc4810a2b47f0bcd.tar.bz2
historical-3746c33cde8ed6871e3f4992dc4810a2b47f0bcd.zip
Version bump
Package-Manager: portage-2.1.2_rc1-r4
Diffstat (limited to 'gnome-extra/gcalctool/gcalctool-5.8.25.ebuild')
-rw-r--r--gnome-extra/gcalctool/gcalctool-5.8.25.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnome-extra/gcalctool/gcalctool-5.8.25.ebuild b/gnome-extra/gcalctool/gcalctool-5.8.25.ebuild
new file mode 100644
index 000000000000..2c5645f9d12a
--- /dev/null
+++ b/gnome-extra/gcalctool/gcalctool-5.8.25.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/gcalctool/gcalctool-5.8.25.ebuild,v 1.1 2006/11/06 13:54:52 leio Exp $
+
+inherit eutils gnome2
+
+DESCRIPTION="A calculator application for GNOME"
+HOMEPAGE="http://calctool.sourceforge.net/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2.6
+ >=dev-libs/glib-2
+ >=dev-libs/atk-1.5
+ >=gnome-base/libgnome-2
+ >=gnome-base/libgnomeui-2
+ >=gnome-base/gconf-2"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ app-text/scrollkeeper
+ >=dev-util/intltool-0.35
+ >=dev-util/pkgconfig-0.9
+ >=app-text/gnome-doc-utils-0.3.2"
+
+DOCS="AUTHORS ChangeLog* MAINTAINERS NEWS README TODO"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-gnome"
+}
+
+src_install() {
+ gnome2_src_install
+
+ # remove symlink that conflicts with <2.3 gnome-utils
+ rm -f ${D}/usr/bin/gnome-calculator
+}