summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-11-04 17:52:14 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-11-04 17:52:14 +0000
commit767898c822d0b2bf58610bfdf52f7253beaffd9b (patch)
tree2321655ce00f0ee3fd7c9f40188b18fccf1cea44 /gnome-extra/guppi
parentsyntax fixes (diff)
downloadhistorical-767898c822d0b2bf58610bfdf52f7253beaffd9b.tar.gz
historical-767898c822d0b2bf58610bfdf52f7253beaffd9b.tar.bz2
historical-767898c822d0b2bf58610bfdf52f7253beaffd9b.zip
gnumeric support
Diffstat (limited to 'gnome-extra/guppi')
-rw-r--r--gnome-extra/guppi/ChangeLog9
-rw-r--r--gnome-extra/guppi/files/digest-guppi-0.40.3-r21
-rw-r--r--gnome-extra/guppi/guppi-0.40.3-r2.ebuild86
3 files changed, 95 insertions, 1 deletions
diff --git a/gnome-extra/guppi/ChangeLog b/gnome-extra/guppi/ChangeLog
index 6e09a8addac2..99c4dd404d3c 100644
--- a/gnome-extra/guppi/ChangeLog
+++ b/gnome-extra/guppi/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for gnome-extra/guppi
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/gnome-extra/guppi/ChangeLog,v 1.4 2002/09/01 08:04:04 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/guppi/ChangeLog,v 1.5 2002/11/04 17:52:14 azarah Exp $
+
+*guppi-0.40.3-r2 (4 Nov 2002)
+
+ 4 Nov 2002; Martin Schlemmer <azarah@gentoo.org> :
+ Add the --with-gnumeric option back again, thanks to
+ Eric Andresen <ndiin1@cox.net> for noticing that it got
+ missing.
*guppi-0.40.3-r1 (16 Mar 2002)
diff --git a/gnome-extra/guppi/files/digest-guppi-0.40.3-r2 b/gnome-extra/guppi/files/digest-guppi-0.40.3-r2
new file mode 100644
index 000000000000..21bfb50a1365
--- /dev/null
+++ b/gnome-extra/guppi/files/digest-guppi-0.40.3-r2
@@ -0,0 +1 @@
+MD5 26ec6eb5b6fe7fb4e32ecff64d4f1b16 Guppi-0.40.3.tar.bz2 1016831
diff --git a/gnome-extra/guppi/guppi-0.40.3-r2.ebuild b/gnome-extra/guppi/guppi-0.40.3-r2.ebuild
new file mode 100644
index 000000000000..270493935506
--- /dev/null
+++ b/gnome-extra/guppi/guppi-0.40.3-r2.ebuild
@@ -0,0 +1,86 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/guppi/guppi-0.40.3-r2.ebuild,v 1.1 2002/11/04 17:52:14 azarah Exp $
+
+IUSE="python nls readline"
+
+MY_P=${P/guppi/Guppi}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="GNOME Plotting Tool"
+# ftp.gnome.org is slooow in updating ;/
+SRC_URI="ftp://ftp.yggdrasil.com/mirrors/site/ftp.gnome.org/pub/GNOME/stable/sources/Guppi/${MY_P}.tar.bz2
+ ftp://ftp.gnome.org/pub/GNOME/stable/sources/Guppi/${MY_P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/guppi/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="x86 ppc sparc sparc64"
+
+
+RDEPEND="=x11-libs/gtk+-1.2*
+ >=gnome-base/gnome-libs-1.4.1.2
+ >=gnome-base/oaf-0.6.7
+ <gnome-base/libglade-0.90
+ >=gnome-base/gnome-print-0.31
+ >=media-libs/gdk-pixbuf-0.13
+ >=dev-util/guile-1.4
+ >=gnome-base/bonobo-1.0.17"
+
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext
+ >=dev-util/intltool-0.11 )
+ python? ( >=dev-lang/python-2.0 )"
+
+src_compile() {
+
+ local myconf
+
+ if [ "`use python`" ]
+ then
+ myconf="${myconf} --enable-python"
+ else
+ myconf="${myconf} --disable-python"
+ fi
+
+ if [ -z "`use nls`" ] ; then
+ myconf="${myconf} --disable-nls"
+ fi
+
+ if [ -z "`use readline`" ] ; then
+ myconf="${myconf} --disable-guile-readline"
+ fi
+
+ # We need this for gnumeric support. Note that you do
+ # not need gnumeric installed for this to work.
+ myconf="${myconf} -enable-gnumeric"
+
+# to compile with guile-1.5
+# CFLAGS="${CFLAGS} -DGUPPI_USING_NEWER_GUILE `gnome-config --cflags libglade`"
+
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --with-bonobo \
+ ${myconf} || die
+
+ # The python 'generate' module opens some files in rw mode for some
+ # unknown reason.
+ addwrite "/usr/lib/python2.0/"
+ addwrite "/usr/lib/python2.1/"
+ addwrite "/usr/lib/python2.2/"
+
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ sysconfdir=${D}/etc \
+ localstatedir=${D}/var/lib \
+ install || die
+
+ dodoc AUTHORS COPYING ChangeLog NEWS README TODO
+}