summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlastair Tse <liquidx@gentoo.org>2003-09-17 20:12:23 +0000
committerAlastair Tse <liquidx@gentoo.org>2003-09-17 20:12:23 +0000
commit6b1ec811d151d4026ccba4243700eabdd37e98a4 (patch)
treee670ce8965515d51cce82213351d41a02fe5e73d /gnome-extra/libgsf/libgsf-1.8.2.ebuild
parentversion bump (diff)
downloadhistorical-6b1ec811d151d4026ccba4243700eabdd37e98a4.tar.gz
historical-6b1ec811d151d4026ccba4243700eabdd37e98a4.tar.bz2
historical-6b1ec811d151d4026ccba4243700eabdd37e98a4.zip
version bump
Diffstat (limited to 'gnome-extra/libgsf/libgsf-1.8.2.ebuild')
-rw-r--r--gnome-extra/libgsf/libgsf-1.8.2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnome-extra/libgsf/libgsf-1.8.2.ebuild b/gnome-extra/libgsf/libgsf-1.8.2.ebuild
new file mode 100644
index 000000000000..8ca06077557c
--- /dev/null
+++ b/gnome-extra/libgsf/libgsf-1.8.2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgsf/libgsf-1.8.2.ebuild,v 1.1 2003/09/17 20:12:18 liquidx Exp $
+
+inherit gnome2
+
+DESCRIPTION="The GNOME Structured File Library"
+HOMEPAGE="http://www.gnome.org/"
+
+IUSE="gnome doc"
+SLOT="0"
+LICENSE="GPL-2 LGPL-2.1"
+KEYWORDS="~x86 ~sparc ~ppc ~hppa"
+
+# FIXME : should add optional bz2 support
+RDEPEND=">=dev-libs/libxml2-2.4.16
+ >=dev-libs/glib-2
+ >=sys-libs/zlib-1.1.4
+ gnome? ( >=gnome-base/libbonobo-2
+ >=gnome-base/gnome-vfs-2 )"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=sys-apps/sed-4
+ doc? ( >=dev-util/gtk-doc-0.9 )"
+
+src_unpack() {
+ unpack ${A}
+ sed -e "s:doc\$(TARGET_DIR):\$(TARGET_DIR):" \
+ -i ${S}/doc/Makefile.in
+}
+
+G2CONF="${G2CONF} $(use_with gnome)"
+
+DOCS="AUTHORS COPYING* ChangeLog INSTALL NEWS README"