summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Scherbaum <dertobi123@gentoo.org>2009-05-17 12:58:17 +0000
committerTobias Scherbaum <dertobi123@gentoo.org>2009-05-17 12:58:17 +0000
commitfe59984d36aad7186427f5b80617df829a77c7f5 (patch)
treece708dbc6157192993e503424f1b8837812f6cfe /gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
parentMask the upcoming automake 1.11 beta. (diff)
downloadhistorical-fe59984d36aad7186427f5b80617df829a77c7f5.tar.gz
historical-fe59984d36aad7186427f5b80617df829a77c7f5.tar.bz2
historical-fe59984d36aad7186427f5b80617df829a77c7f5.zip
Initial import, based on an ebuild by me from the gentoo-de overlay. Closed #108419
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64
Diffstat (limited to 'gnome-extra/wp_tray/wp_tray-0.5.5.ebuild')
-rw-r--r--gnome-extra/wp_tray/wp_tray-0.5.5.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild b/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
new file mode 100644
index 000000000000..a84b99d916cd
--- /dev/null
+++ b/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2009 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/wp_tray/wp_tray-0.5.5.ebuild,v 1.1 2009/05/17 12:58:17 dertobi123 Exp $
+
+inherit gnome2 multilib eutils
+
+DESCRIPTION="Wallpaper Manager for the Gnome Desktop"
+HOMEPAGE="http://planetearthworm.com/projects/wp_tray"
+
+SRC_URI="http://planetearthworm.com/projects/${PN}/files/${P}.tar.gz"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=gnome-base/libgnomeui-2
+ >=x11-libs/gtk+-2
+ >=gnome-base/libglade-2
+ dev-cpp/libgnomeuimm
+ dev-cpp/libxmlpp"
+
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ dev-libs/boost"
+
+src_compile() {
+ local myconf
+
+ myconf="${myconf} --with-boostfilesystem=/usr/$(get_libdir)/libboost_filesystem.so"
+ myconf="${myconf} --with-boostregex=/usr/$(get_libdir)/libboost_regex.so"
+
+ econf ${myconf} || die "Configure failure"
+ emake || die "Make failure"
+}
+
+src_install() {
+ addpredict /root/.gconf
+ gnome2_src_install
+}
+
+DOCS="AUTHORS ChangeLog INSTALL NEWS README*"
+