summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2007-10-08 19:58:47 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2007-10-08 19:58:47 +0000
commite833a6def818c1e34fed0099192ff94a77f3659a (patch)
tree1a81105d429cd4c810b290c8442a16fc078b5d4d /gnustep-libs/camaelon/camaelon-0.2.ebuild
parentStable on ppc64; bug #189738 (diff)
downloadhistorical-e833a6def818c1e34fed0099192ff94a77f3659a.tar.gz
historical-e833a6def818c1e34fed0099192ff94a77f3659a.tar.bz2
historical-e833a6def818c1e34fed0099192ff94a77f3659a.zip
Version bump from the GNUstep overlay
Package-Manager: portage-2.1.3.12
Diffstat (limited to 'gnustep-libs/camaelon/camaelon-0.2.ebuild')
-rw-r--r--gnustep-libs/camaelon/camaelon-0.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnustep-libs/camaelon/camaelon-0.2.ebuild b/gnustep-libs/camaelon/camaelon-0.2.ebuild
new file mode 100644
index 000000000000..51e8fbbf4f88
--- /dev/null
+++ b/gnustep-libs/camaelon/camaelon-0.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-libs/camaelon/camaelon-0.2.ebuild,v 1.1 2007/10/08 19:58:46 voyageur Exp $
+
+inherit gnustep-2
+
+S="${WORKDIR}/Etoile-${PV}/Bundles/${PN/c/C}"
+
+DESCRIPTION="Camaelon allows you to load theme bundles for GNUstep."
+
+HOMEPAGE="http://www.etoile-project.org"
+SRC_URI="http://download.gna.org/etoile/etoile-${PV}.tar.gz"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+src_install() {
+ gnustep-base_src_install
+
+ #Link default theme
+ dodir ${GNUSTEP_SYSTEM_LIBRARY}/Themes
+ dosym ${GNUSTEP_SYSTEM_LIBRARY}/Bundles/Camaelon.themeEngine/Resources/Nesedah.theme ${GNUSTEP_SYSTEM_LIBRARY}/Themes/
+}
+
+gnustep_config_script() {
+ echo "gnustep_append_default NSGlobalDomain GSAppKitUserBundles \"${GNUSTEP_SYSTEM_LIBRARY}/Bundles/Camaelon.themeEngine\""
+ echo "gnustep_set_default Camaelon Theme Nesedah"
+}