summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commit3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe (patch)
tree354eb455031cc91369bff38098f7636aa38ecdad /kde-base/dolphin-plugins
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadhistorical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.tar.gz
historical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.tar.bz2
historical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.zip
[kde-base] Add KDE SC 4.6.0
Package-Manager: portage-2.2.0_alpha19_p2/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/dolphin-plugins')
-rw-r--r--kde-base/dolphin-plugins/ChangeLog8
-rw-r--r--kde-base/dolphin-plugins/dolphin-plugins-4.6.0.ebuild39
-rw-r--r--kde-base/dolphin-plugins/metadata.xml3
3 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/dolphin-plugins/ChangeLog b/kde-base/dolphin-plugins/ChangeLog
index 682f5acc4ee2..7eec7fe2c7f9 100644
--- a/kde-base/dolphin-plugins/ChangeLog
+++ b/kde-base/dolphin-plugins/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/dolphin-plugins
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.8 2011/01/10 11:53:19 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/ChangeLog,v 1.9 2011/01/26 20:28:42 alexxy Exp $
+
+*dolphin-plugins-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +dolphin-plugins-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*dolphin-plugins-4.5.5 (10 Jan 2011)
diff --git a/kde-base/dolphin-plugins/dolphin-plugins-4.6.0.ebuild b/kde-base/dolphin-plugins/dolphin-plugins-4.6.0.ebuild
new file mode 100644
index 000000000000..73ac54affe8f
--- /dev/null
+++ b/kde-base/dolphin-plugins/dolphin-plugins-4.6.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin-plugins/dolphin-plugins-4.6.0.ebuild,v 1.1 2011/01/26 20:28:42 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdesdk"
+inherit kde4-meta
+
+DESCRIPTION="Extra Dolphin plugins"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +git +subversion"
+
+DEPEND="
+ $(add_kdebase_dep libkonq)
+"
+RDEPEND="${DEPEND}
+ $(add_kdebase_dep kompare)
+ git? ( dev-vcs/git )
+ subversion? ( dev-vcs/subversion )
+"
+
+# SCM plugins moved from dolphin somewhere before 4.4.75
+add_blocker dolphin '<4.4.75'
+
+KMLOADLIBS="libkonq"
+
+src_prepare() {
+ echo 'macro_optional_add_subdirectory ( dolphin-plugins )' >> CMakeLists.txt || die
+ echo > dolphin-plugins/CMakeLists.txt || die
+ use git && echo 'add_subdirectory ( git )' >> dolphin-plugins/CMakeLists.txt
+ use subversion && echo 'add_subdirectory ( svn )' >> dolphin-plugins/CMakeLists.txt
+
+ kde4-meta_src_prepare
+}
+
+src_install() {
+ ( ! use git && ! use subversion ) || kde4-meta_src_install
+}
diff --git a/kde-base/dolphin-plugins/metadata.xml b/kde-base/dolphin-plugins/metadata.xml
index 8d1e86a9cefb..ae1e2aa06868 100644
--- a/kde-base/dolphin-plugins/metadata.xml
+++ b/kde-base/dolphin-plugins/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>kde</herd>
+<use>
+<flag name="git">Enable support for the git VCS</flag>
+</use>
</pkgmetadata>