summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-06-04 13:56:48 +0000
commit5a13ccd21de0abab5282365a5070ba7229e9b098 (patch)
tree0793ec455fa77a823da333d1bf4faf15ecd53b10 /kde-base/dolphin
parentFix variable test. Thx to salnx per forums for the fix. (diff)
downloadhistorical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.gz
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.tar.bz2
historical-5a13ccd21de0abab5282365a5070ba7229e9b098.zip
Version bump KDE 4.2.4
Package-Manager: portage-2.2_rc33/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/dolphin')
-rw-r--r--kde-base/dolphin/ChangeLog7
-rw-r--r--kde-base/dolphin/dolphin-4.2.4-r1.ebuild34
2 files changed, 40 insertions, 1 deletions
diff --git a/kde-base/dolphin/ChangeLog b/kde-base/dolphin/ChangeLog
index 6a92dffa20ee..fd9953cd5038 100644
--- a/kde-base/dolphin/ChangeLog
+++ b/kde-base/dolphin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/dolphin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.33 2009/06/03 14:33:58 alexxy Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/ChangeLog,v 1.34 2009/06/04 11:06:54 alexxy Exp $
+
+*dolphin-4.2.4-r1 (04 Jun 2009)
+
+ 04 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> +dolphin-4.2.4-r1.ebuild:
+ Version bump
03 Jun 2009; Alexey Shvetsov <alexxy@gentoo.org> -dolphin-4.2.2.ebuild,
-dolphin-4.2.2-r1.ebuild:
diff --git a/kde-base/dolphin/dolphin-4.2.4-r1.ebuild b/kde-base/dolphin/dolphin-4.2.4-r1.ebuild
new file mode 100644
index 000000000000..e7ebe2d0d48f
--- /dev/null
+++ b/kde-base/dolphin/dolphin-4.2.4-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dolphin/dolphin-4.2.4-r1.ebuild,v 1.1 2009/06/04 11:06:54 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-apps"
+inherit kde4-meta
+
+DESCRIPTION="A KDE filemanager focusing on usability"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug +handbook +semantic-desktop thumbnail"
+
+DEPEND="
+ >=kde-base/kdelibs-${PV}:${SLOT}[kdeprefix=,semantic-desktop=]
+ >=kde-base/libkonq-${PV}:${SLOT}[kdeprefix=]
+"
+RDEPEND="${DEPEND}
+ >=kde-base/kfind-${PV}:${SLOT}[kdeprefix=]
+ semantic-desktop? ( >=kde-base/nepomuk-${PV}:${SLOT}[kdeprefix=] )
+"
+PDEPEND="
+ thumbnail? ( media-video/mplayerthumbs:1 )
+"
+
+KMLOADLIBS="libkonq"
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)"
+
+ kde4-meta_src_configure
+}