summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2010-06-30 15:37:09 +0000
commitaa66be86a5a6d313a757a8082822195e32ec6d44 (patch)
tree216e32b289318ecc6cc5c758e202354a9ced5982 /kde-base/kalgebra
parentUse --with-optim to respect CFLAGS (bug #261214). (diff)
downloadhistorical-aa66be86a5a6d313a757a8082822195e32ec6d44.tar.gz
historical-aa66be86a5a6d313a757a8082822195e32ec6d44.tar.bz2
historical-aa66be86a5a6d313a757a8082822195e32ec6d44.zip
[kde-base] Bump KDE SC 4.4.5 =)
Package-Manager: portage-2.2_rc67_p182/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kalgebra')
-rw-r--r--kde-base/kalgebra/ChangeLog7
-rw-r--r--kde-base/kalgebra/kalgebra-4.4.5.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/kde-base/kalgebra/ChangeLog b/kde-base/kalgebra/ChangeLog
index 0edd2a585060..9bc91e494291 100644
--- a/kde-base/kalgebra/ChangeLog
+++ b/kde-base/kalgebra/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kalgebra
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.65 2010/06/27 09:46:12 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/ChangeLog,v 1.66 2010/06/30 15:36:27 alexxy Exp $
+
+*kalgebra-4.4.5 (30 Jun 2010)
+
+ 30 Jun 2010; Alexey Shvetsov <alexxy@gentoo.org> +kalgebra-4.4.5.ebuild:
+ Version bump
27 Jun 2010; Christian Faulhammer <fauli@gentoo.org>
kalgebra-4.4.4.ebuild:
diff --git a/kde-base/kalgebra/kalgebra-4.4.5.ebuild b/kde-base/kalgebra/kalgebra-4.4.5.ebuild
new file mode 100644
index 000000000000..4e1e624c5a08
--- /dev/null
+++ b/kde-base/kalgebra/kalgebra-4.4.5.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalgebra/kalgebra-4.4.5.ebuild,v 1.1 2010/06/30 15:36:27 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdeedu"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="MathML-based graph calculator for KDE."
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="debug +handbook +plasma readline"
+
+DEPEND="
+ readline? ( sys-libs/readline )
+"
+RDEPEND="${DEPEND}"
+
+KMEXTRACTONLY="libkdeedu/kdeeduui"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-4.3.2-solaris-graph2d.patch
+)
+
+src_configure() {
+ mycmakeargs=(
+ $(cmake-utils_use_with readline)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with opengl OpenGL)
+ )
+
+ kde4-meta_src_configure
+}
+
+src_test() {
+ # disable broken test
+ sed -i -e '/mathmlpresentationtest/ s/^/#DO_NOT_RUN_TEST /' \
+ "${S}"/"${PN}"/analitza/tests/CMakeLists.txt || \
+ die "sed to disable mathmlpresentationtest failed."
+
+ kde4-meta_src_test
+}