summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-02-20 23:36:47 +0000
commit86166760b8aa7e1c789581787e2f7bd3d159df87 (patch)
tree3c1095c1c98ae9f6510c9d93134aa0062970a3bd /kde-base/kalzium
parentEnabled support for openmpi and mpich2 (see bug #210639). (diff)
downloadhistorical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.gz
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.tar.bz2
historical-86166760b8aa7e1c789581787e2f7bd3d159df87.zip
Version bump to KDE 3.5.9.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kalzium')
-rw-r--r--kde-base/kalzium/ChangeLog8
-rw-r--r--kde-base/kalzium/kalzium-3.5.9.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/kde-base/kalzium/ChangeLog b/kde-base/kalzium/ChangeLog
index 48e876edba86..91e3372b2842 100644
--- a/kde-base/kalzium/ChangeLog
+++ b/kde-base/kalzium/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kalzium
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.85 2008/02/17 02:53:15 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/ChangeLog,v 1.86 2008/02/20 22:34:44 philantrop Exp $
+
+*kalzium-3.5.9 (20 Feb 2008)
+
+ 20 Feb 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +kalzium-3.5.9.ebuild:
+ Version bump to KDE 3.5.9.
16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org> -kalzium-3.5.5.ebuild,
-kalzium-3.5.6.ebuild, -kalzium-3.5.7.ebuild, -kalzium-4.0.0.ebuild:
diff --git a/kde-base/kalzium/kalzium-3.5.9.ebuild b/kde-base/kalzium/kalzium-3.5.9.ebuild
new file mode 100644
index 000000000000..1f24868222df
--- /dev/null
+++ b/kde-base/kalzium/kalzium-3.5.9.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kalzium/kalzium-3.5.9.ebuild,v 1.1 2008/02/20 22:34:44 philantrop Exp $
+KMNAME=kdeedu
+EAPI="1"
+inherit flag-o-matic kde-meta eutils
+
+DESCRIPTION="KDE: periodic table of the elements"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="solver"
+HOMEPAGE="http://edu.kde.org/kalzium"
+
+DEPEND=">=kde-base/libkdeedu-${PV}:${SLOT}
+ solver? ( >=dev-ml/facile-1.1 )"
+
+KMEXTRACTONLY="libkdeedu/kdeeduplot
+ libkdeedu/kdeeduui"
+KMCOPYLIB="libkdeeduplot libkdeedu/kdeeduplot
+ libkdeeduui libkdeedu/kdeeduui"
+
+PATCHES="${FILESDIR}/${PN}-3.5.7-copy_string.patch"
+
+pkg_setup() {
+ if use solver && ! built_with_use --missing true dev-lang/ocaml ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-lang/ocaml built with the ocamlopt useflag"
+ eerror "in order to get a native code ocaml compiler"
+ die "Please install dev-lang/ocaml with ocamlopt support"
+ fi
+ if use solver && ! built_with_use --missing true dev-ml/facile ocamlopt; then
+ eerror "In order to build the solver for ${PN}, you first need"
+ eerror "to have dev-ml/facile built with the ocamlopt useflag"
+ eerror "in order to get the native code library"
+ die "Please install dev-ml/facile with ocamlopt support"
+ fi
+ kde_pkg_setup
+}
+
+src_compile() {
+ append-ldflags -Wl,-z,noexecstack
+
+ local myconf="$(use_enable solver ocamlsolver)"
+
+ if use solver ; then
+ cd "${S}/${PN}/src/solver"
+ emake || die "compiling the ocaml resolver failed"
+ fi
+
+ kde-meta_src_compile
+}