summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-31 21:44:45 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2005-12-31 21:44:45 +0000
commitca38d7ef777af7345ffd905f82d9f2d2507606cc (patch)
tree19abc1b81f4b30de457da7ab62812cacd2e55e70 /kde-base/kcontrol
parentppc love (diff)
downloadhistorical-ca38d7ef777af7345ffd905f82d9f2d2507606cc.tar.gz
historical-ca38d7ef777af7345ffd905f82d9f2d2507606cc.tar.bz2
historical-ca38d7ef777af7345ffd905f82d9f2d2507606cc.zip
Add patch to use the global usb.ids file, and add usbutils as a dep to have that file.
Package-Manager: portage-2.1_pre3
Diffstat (limited to 'kde-base/kcontrol')
-rw-r--r--kde-base/kcontrol/ChangeLog7
-rw-r--r--kde-base/kcontrol/files/kcontrol-3.5.0-global-usbids.patch62
-rw-r--r--kde-base/kcontrol/kcontrol-3.5.0.ebuild8
3 files changed, 74 insertions, 3 deletions
diff --git a/kde-base/kcontrol/ChangeLog b/kde-base/kcontrol/ChangeLog
index d7af96d4c236..24b90feafc7f 100644
--- a/kde-base/kcontrol/ChangeLog
+++ b/kde-base/kcontrol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kcontrol
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.45 2005/12/17 09:36:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/ChangeLog,v 1.46 2005/12/31 21:42:41 flameeyes Exp $
+
+ 31 Dec 2005; Diego Pettenò <flameeyes@gentoo.org>
+ +files/kcontrol-3.5.0-global-usbids.patch, kcontrol-3.5.0.ebuild:
+ Add patch to use the global usb.ids file, and add usbutils as a dep to have
+ that file.
17 Dec 2005; Markus Rothe <corsair@gentoo.org> kcontrol-3.5.0.ebuild:
Added ~ppc64
diff --git a/kde-base/kcontrol/files/kcontrol-3.5.0-global-usbids.patch b/kde-base/kcontrol/files/kcontrol-3.5.0-global-usbids.patch
new file mode 100644
index 000000000000..9a04f685fc45
--- /dev/null
+++ b/kde-base/kcontrol/files/kcontrol-3.5.0-global-usbids.patch
@@ -0,0 +1,62 @@
+Index: kcontrol/usbview/usbdb.cpp
+===================================================================
+--- kcontrol/usbview/usbdb.cpp (revision 492938)
++++ kcontrol/usbview/usbdb.cpp (working copy)
+@@ -8,6 +8,7 @@
+ * *
+ ***************************************************************************/
+
++#include <config.h>
+
+ #include <iostream>
+
+@@ -24,7 +25,11 @@
+
+ USBDB::USBDB()
+ {
++#ifndef USBIDS_FILE
+ QString db = locate("data", "kcmusb/usb.ids");
++#else
++ QString db = USBIDS_FILE;
++#endif
+ if (db.isEmpty())
+ return;
+
+Index: kcontrol/usbview/Makefile.am
+===================================================================
+--- kcontrol/usbview/Makefile.am (revision 492938)
++++ kcontrol/usbview/Makefile.am (working copy)
+@@ -14,6 +14,8 @@
+
+ xdg_apps_DATA = kcmusb.desktop
+
++if install_usbids
+ usb_DATA = usb.ids
+ usbdir = $(kde_datadir)/kcmusb
++endif
+
+Index: kcontrol/usbview/configure.in.in
+===================================================================
+--- kcontrol/usbview/configure.in.in (revision 492938)
++++ kcontrol/usbview/configure.in.in (working copy)
+@@ -1,10 +1,16 @@
+ case "$host" in
+- *-*-linux*)
++ *-*-linux*|*-*-freebsd*)
+ FOUND_USBVIEW=yes
+ ;;
+- *-*-freebsd*)
+- FOUND_USBVIEW=yes
+- ;;
+ esac
+
+ AM_CONDITIONAL(include_kcontrol_usbview, test "$FOUND_USBVIEW" = "yes")
++
++AC_ARG_WITH([usbids], AC_HELP_STRING([--with-usbids=PATH], [Use the usb.ids file at the specified path, instead of the local copy]))
++
++if test "x$with_usbids" != "x" && test "x$with_usbids" != "xno"; then
++ AC_DEFINE_UNQUOTED(USBIDS_FILE, "$with_usbids", [Path for the usb.ids file to use])
++ dont_install_usbids="yes"
++fi
++
++AM_CONDITIONAL(install_usbids, test "x$dont_install_usbids" != "xyes")
diff --git a/kde-base/kcontrol/kcontrol-3.5.0.ebuild b/kde-base/kcontrol/kcontrol-3.5.0.ebuild
index 91b4f3b6a2a1..292e5a40834b 100644
--- a/kde-base/kcontrol/kcontrol-3.5.0.ebuild
+++ b/kde-base/kcontrol/kcontrol-3.5.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/kcontrol-3.5.0.ebuild,v 1.4 2005/12/17 09:36:16 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kcontrol/kcontrol-3.5.0.ebuild,v 1.5 2005/12/31 21:42:41 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
@@ -20,6 +20,7 @@ DEPEND=">=media-libs/freetype-2
logitech-mouse? ( >=dev-libs/libusb-0.1.10a )"
RDEPEND="${DEPEND}
+ sys-apps/usbutils
$(deprange $PV $MAXKDEVER kde-base/kcminit)
$(deprange $PV $MAXKDEVER kde-base/kdebase-data)
$(deprange $PV $MAXKDEVER kde-base/kdesu)
@@ -44,8 +45,11 @@ KMCOPYLIB="libkonq libkonq
libtaskbar kicker/taskbar
libtaskmanager kicker/taskmanager"
+PATCHES="${FILESDIR}/${P}-global-usbids.patch"
+
src_compile() {
myconf="$myconf `use_with ssl` `use_with arts` `use_with opengl gl`
- `use_with ieee1394 libraw1394` `use_with logitech-mouse libusb`"
+ `use_with ieee1394 libraw1394` `use_with logitech-mouse libusb`
+ --with-usbids=/usr/share/misc/usb.ids"
kde-meta_src_compile
}