summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2011-01-26 20:29:26 +0000
commit3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe (patch)
tree354eb455031cc91369bff38098f7636aa38ecdad /kde-base/kdebindings-ruby
parent[profiles] Mask marble with gps on ppc64 (diff)
downloadhistorical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.tar.gz
historical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.tar.bz2
historical-3c0323f9d2990f6ccb8a70eb2ca0172e57f561fe.zip
[kde-base] Add KDE SC 4.6.0
Package-Manager: portage-2.2.0_alpha19_p2/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kdebindings-ruby')
-rw-r--r--kde-base/kdebindings-ruby/ChangeLog8
-rw-r--r--kde-base/kdebindings-ruby/kdebindings-ruby-4.6.0.ebuild93
-rw-r--r--kde-base/kdebindings-ruby/metadata.xml1
3 files changed, 101 insertions, 1 deletions
diff --git a/kde-base/kdebindings-ruby/ChangeLog b/kde-base/kdebindings-ruby/ChangeLog
index eee36ffd06c7..2586dedaf9b1 100644
--- a/kde-base/kdebindings-ruby/ChangeLog
+++ b/kde-base/kdebindings-ruby/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdebindings-ruby
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.27 2011/01/10 11:53:27 tampakrap Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/ChangeLog,v 1.28 2011/01/26 20:29:08 alexxy Exp $
+
+*kdebindings-ruby-4.6.0 (26 Jan 2011)
+
+ 26 Jan 2011; Alexey Shvetsov <alexxy@gentoo.org>
+ +kdebindings-ruby-4.6.0.ebuild:
+ Version bump KDE SC 4.6.0
*kdebindings-ruby-4.5.5 (10 Jan 2011)
diff --git a/kde-base/kdebindings-ruby/kdebindings-ruby-4.6.0.ebuild b/kde-base/kdebindings-ruby/kdebindings-ruby-4.6.0.ebuild
new file mode 100644
index 000000000000..d1847adcc042
--- /dev/null
+++ b/kde-base/kdebindings-ruby/kdebindings-ruby-4.6.0.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdebindings-ruby/kdebindings-ruby-4.6.0.ebuild,v 1.1 2011/01/26 20:29:08 alexxy Exp $
+
+EAPI="3"
+
+KMNAME="kdebindings"
+KMMODULE="ruby"
+WEBKIT_REQUIRED="optional"
+
+USE_RUBY="ruby18"
+# No ruby19 for three reasons:
+# 1) it does not build (yet) - will likely be solved soon
+# 2) cmake bails when configuring twice or more - solved with CMAKE_IN_SOURCE_BUILD=1
+# 3) the ebuild can only be installed for one ruby variant, otherwise the compiled
+# files with identical path+name will overwrite each other - difficult :(
+
+inherit kde4-meta ruby-ng
+
+DESCRIPTION="KDE Ruby bindings"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="akonadi debug kate okular phonon plasma qscintilla qwt semantic-desktop"
+
+# TODO add qt-declarative
+DEPEND="
+ $(add_kdebase_dep smoke 'akonadi?,kate?,okular?,phonon?,qscintilla?,qwt?,semantic-desktop?,webkit?')
+"
+
+ruby_add_bdepend dev-ruby/rubygems
+
+RDEPEND="${DEPEND}
+ !dev-ruby/qt4-qtruby
+"
+
+# Merged with kdebindings-ruby after 4.4.80
+add_blocker krossruby
+
+pkg_setup() {
+ ruby-ng_pkg_setup
+ kde4-meta_pkg_setup
+}
+
+src_unpack() {
+ kde4-meta_src_unpack
+
+ cd "${WORKDIR}"
+ mkdir all
+ mv ${P} all/ || die "Could not move sources"
+}
+
+all_ruby_prepare() {
+ kde4-meta_src_prepare
+
+ sed -i -e "s#smoke/smoke.h#smoke.h#" \
+ ruby/qtruby/src/handlers.cpp \
+ ruby/qtruby/src/marshall.h \
+ ruby/qtruby/src/marshall_types.h \
+ ruby/qtruby/src/Qt.cpp \
+ ruby/qtruby/src/qtruby.cpp \
+ ruby/qtruby/src/qtruby.h \
+ ruby/qtruby/src/smokeruby.h || die
+}
+
+each_ruby_configure() {
+ CMAKE_USE_DIR=${S}
+ mycmakeargs=(
+ -DRUBY_LIBRARY=$(ruby_get_libruby)
+ -DRUBY_INCLUDE_PATH=$(ruby_get_hdrdir)
+ -DRUBY_EXECUTABLE=${RUBY}
+ $(cmake-utils_use_with akonadi)
+ $(cmake-utils_use_with akonadi KdepimLibs)
+ $(cmake-utils_use_disable kate)
+ $(cmake-utils_use_with okular)
+ $(cmake-utils_use_with phonon)
+ $(cmake-utils_use_with plasma)
+ $(cmake-utils_use_with qscintilla QScintilla)
+ $(cmake-utils_use_with qwt Qwt)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with semantic-desktop Soprano)
+ $(cmake-utils_use_disable webkit QtWebKit)
+ )
+ kde4-meta_src_configure
+}
+
+each_ruby_compile() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_compile
+}
+
+each_ruby_install() {
+ CMAKE_USE_DIR=${S}
+ kde4-meta_src_install
+}
diff --git a/kde-base/kdebindings-ruby/metadata.xml b/kde-base/kdebindings-ruby/metadata.xml
index 81e2ae61cbf9..e42966f13e07 100644
--- a/kde-base/kdebindings-ruby/metadata.xml
+++ b/kde-base/kdebindings-ruby/metadata.xml
@@ -4,6 +4,7 @@
<herd>kde</herd>
<use>
<flag name="akonadi">Compile bindings for Akonadi.</flag>
+ <flag name="kate">Compile bindings for KDE Advanced Text Editor.</flag>
<flag name="okular">Compile bindings for <pkg>kde-base/okular</pkg>.</flag>
<flag name="phonon">Compile bindings for Phonon.</flag>
<flag name="plasma">Compile bindings for KDE's Plasma.</flag>