summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGregorio Guidi <greg_g@gentoo.org>2005-10-15 11:08:47 +0000
committerGregorio Guidi <greg_g@gentoo.org>2005-10-15 11:08:47 +0000
commit89192bf2a638769a8fd838c467989707b9d60a50 (patch)
tree20656f73f8920e8636cfa748f224bf20e421f060 /kde-base/kdemultimedia
parentVersion bump, CFLAGS optimization, and amd64 support thanks to Tupone Alfredo... (diff)
downloadhistorical-89192bf2a638769a8fd838c467989707b9d60a50.tar.gz
historical-89192bf2a638769a8fd838c467989707b9d60a50.tar.bz2
historical-89192bf2a638769a8fd838c467989707b9d60a50.zip
Monolithic ebuilds for 3.5.0_beta2. Fix ChangeLogs for split ebuilds. Remove a few unneeded patches.
Package-Manager: portage-2.0.51.22-r3
Diffstat (limited to 'kde-base/kdemultimedia')
-rw-r--r--kde-base/kdemultimedia/ChangeLog8
-rw-r--r--kde-base/kdemultimedia/files/digest-kdemultimedia-3.5.0_beta21
-rw-r--r--kde-base/kdemultimedia/kdemultimedia-3.5.0_beta2.ebuild63
3 files changed, 71 insertions, 1 deletions
diff --git a/kde-base/kdemultimedia/ChangeLog b/kde-base/kdemultimedia/ChangeLog
index cb6cc6c91097..dffa4a0697c0 100644
--- a/kde-base/kdemultimedia/ChangeLog
+++ b/kde-base/kdemultimedia/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kdemultimedia
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/ChangeLog,v 1.175 2005/10/13 00:09:53 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/ChangeLog,v 1.176 2005/10/15 11:08:41 greg_g Exp $
+
+*kdemultimedia-3.5.0_beta2 (15 Oct 2005)
+
+ 15 Oct 2005; Gregorio Guidi <greg_g@gentoo.org>
+ +kdemultimedia-3.5.0_beta2.ebuild:
+ New version.
*kdemultimedia-3.4.3 (13 Oct 2005)
diff --git a/kde-base/kdemultimedia/files/digest-kdemultimedia-3.5.0_beta2 b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.5.0_beta2
new file mode 100644
index 000000000000..e11acb018f03
--- /dev/null
+++ b/kde-base/kdemultimedia/files/digest-kdemultimedia-3.5.0_beta2
@@ -0,0 +1 @@
+MD5 a0c0f8986b42993b405e35b9a4a59977 kdemultimedia-3.4.92.tar.bz2 5512538
diff --git a/kde-base/kdemultimedia/kdemultimedia-3.5.0_beta2.ebuild b/kde-base/kdemultimedia/kdemultimedia-3.5.0_beta2.ebuild
new file mode 100644
index 000000000000..137f03320025
--- /dev/null
+++ b/kde-base/kdemultimedia/kdemultimedia-3.5.0_beta2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdemultimedia/kdemultimedia-3.5.0_beta2.ebuild,v 1.1 2005/10/15 11:08:41 greg_g Exp $
+
+inherit kde-dist
+
+DESCRIPTION="KDE multimedia apps: noatun, kscd, juk..."
+
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="alsa audiofile encode flac gstreamer mp3 musicbrainz theora vorbis xine"
+
+DEPEND="~kde-base/kdebase-${PV}
+ media-sound/cdparanoia
+ media-libs/akode
+ >=media-libs/taglib-1.2
+ audiofile? ( media-libs/audiofile )
+ xine? ( >=media-libs/xine-lib-1.0 )
+ alsa? ( media-libs/alsa-lib )
+ theora? ( media-libs/libtheora )
+ gstreamer? ( >=media-libs/gstreamer-0.8
+ >=media-libs/gst-plugins-0.8 )
+ musicbrainz? ( media-libs/tunepimp
+ media-libs/musicbrainz )
+ encode? ( mp3? ( media-sound/lame )
+ vorbis? ( media-sound/vorbis-tools )
+ flac? ( media-libs/flac ) )"
+
+RDEPEND="${DEPEND}
+ gstreamer? ( mp3? ( >=media-plugins/gst-plugins-mad-0.8 )
+ vorbis? ( >=media-plugins/gst-plugins-ogg-0.8
+ >=media-plugins/gst-plugins-vorbis-0.8 )
+ flac? ( >=media-plugins/gst-plugins-flac-0.8 ) )"
+
+DEPEND="${DEPEND}
+ dev-util/pkgconfig"
+
+src_compile() {
+ local myconf="--with-cdparanoia --with-taglib
+ --with-akode $(use_with alsa)
+ $(use_with audiofile) $(use_with gstreamer)
+ $(use_with xine) $(use_with theora)
+ $(use_with musicbrainz)"
+
+ # encoding can happen through:
+ # - kio_audiocd (based on libflac for flac,
+ # on libvorbis for vorbis, on the lame binary for mp3)
+ # - kaudiocreator (based on the flac binary for flac,
+ # on the lame binary for mp3, on the oggenc binary for vorbis)
+ # - krec (based on libvorbis for vorbis,
+ # on libmp3lame for mp3)
+ if use encode; then
+ myconf="${myconf} $(use_with mp3 lame)
+ $(use_with vorbis) $(use_with flac)"
+ else
+ myconf="${myconf} --without-lame
+ --without-vorbis --without-flac"
+ fi
+
+ # Not used anymore and scheduled for removal.
+ export DO_NOT_COMPILE="${DO_NOT_COMPILE} mpeglib mpeglib_artsplug"
+
+ kde_src_compile
+}