summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-08-07 11:05:11 +0000
committerJohannes Huber <johu@gentoo.org>2012-08-07 11:05:11 +0000
commit4a4381d8692fbe3a8fc31fa5e386f0914bb304a0 (patch)
treeabf20b1296f6fb4d1cce873f4c7320543eb53ab0 /kde-base/kdeplasma-addons
parentStable arm, bug #428900 (diff)
downloadhistorical-4a4381d8692fbe3a8fc31fa5e386f0914bb304a0.tar.gz
historical-4a4381d8692fbe3a8fc31fa5e386f0914bb304a0.tar.bz2
historical-4a4381d8692fbe3a8fc31fa5e386f0914bb304a0.zip
Version bump KDE SC 4.8.5
Package-Manager: portage-2.2.0_alpha120/cvs/Linux i686
Diffstat (limited to 'kde-base/kdeplasma-addons')
-rw-r--r--kde-base/kdeplasma-addons/ChangeLog7
-rw-r--r--kde-base/kdeplasma-addons/kdeplasma-addons-4.8.5.ebuild59
2 files changed, 65 insertions, 1 deletions
diff --git a/kde-base/kdeplasma-addons/ChangeLog b/kde-base/kdeplasma-addons/ChangeLog
index ba2318bd4220..7e985e7506ed 100644
--- a/kde-base/kdeplasma-addons/ChangeLog
+++ b/kde-base/kdeplasma-addons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdeplasma-addons
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.139 2012/08/01 22:17:36 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/ChangeLog,v 1.140 2012/08/07 11:04:25 johu Exp $
+
+*kdeplasma-addons-4.8.5 (07 Aug 2012)
+
+ 07 Aug 2012; Johannes Huber <johu@gentoo.org> +kdeplasma-addons-4.8.5.ebuild:
+ Version bump KDE SC 4.8.5
*kdeplasma-addons-4.9.0 (01 Aug 2012)
diff --git a/kde-base/kdeplasma-addons/kdeplasma-addons-4.8.5.ebuild b/kde-base/kdeplasma-addons/kdeplasma-addons-4.8.5.ebuild
new file mode 100644
index 000000000000..7a227f3724fb
--- /dev/null
+++ b/kde-base/kdeplasma-addons/kdeplasma-addons-4.8.5.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdeplasma-addons/kdeplasma-addons-4.8.5.ebuild,v 1.1 2012/08/07 11:04:25 johu Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+inherit kde4-base
+
+DESCRIPTION="Extra Plasma applets and engines"
+HOMEPAGE="http://www.kde.org/"
+LICENSE="GPL-2 LGPL-2"
+
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="attica debug desktopglobe exif fcitx ibus qalculate qwt scim semantic-desktop"
+
+# krunner is only needed to generate dbus interface for lancelot
+COMMON_DEPEND="
+ app-crypt/qca:2
+ app-crypt/qca-ossl:2
+ $(add_kdebase_dep kdelibs 'semantic-desktop=')
+ $(add_kdebase_dep krunner)
+ $(add_kdebase_dep plasma-workspace 'semantic-desktop=')
+ x11-misc/shared-mime-info
+ attica? ( dev-libs/libattica )
+ desktopglobe? ( $(add_kdebase_dep marble) )
+ exif? ( $(add_kdebase_dep libkexiv2) )
+ fcitx? ( app-i18n/fcitx[dbus(+)] )
+ ibus? ( app-i18n/ibus )
+ qalculate? ( sci-libs/libqalculate )
+ qwt? ( x11-libs/qwt:5 )
+ scim? ( app-i18n/scim )
+ semantic-desktop? (
+ $(add_kdebase_dep kdepimlibs 'semantic-desktop')
+ $(add_kdebase_dep plasma-workspace 'rss')
+ )
+"
+DEPEND="${COMMON_DEPEND}
+ dev-cpp/eigen:2
+"
+RDEPEND="${COMMON_DEPEND}
+"
+
+src_configure() {
+ mycmakeargs=(
+ -DDBUS_INTERFACES_INSTALL_DIR="${EPREFIX}/usr/share/dbus-1/interfaces/"
+ $(cmake-utils_use_with attica LibAttica)
+ $(cmake-utils_use_with desktopglobe Marble)
+ $(cmake-utils_use_with exif Kexiv2)
+ $(cmake-utils_use_with ibus)
+ $(cmake-utils_use_with qalculate)
+ $(cmake-utils_use_with qwt)
+ $(cmake-utils_use_with semantic-desktop KdepimLibs)
+ $(cmake-utils_use_with semantic-desktop Nepomuk)
+ $(cmake-utils_use_with scim)
+ )
+
+ kde4-base_src_configure
+}