summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-02-17 03:31:00 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-02-17 03:31:00 +0000
commit1f0d82e30a76e7b698e006c0b23ef4ba43d716db (patch)
tree71740acf58d3dc2cadad8ebbfe1669f80226a1ea /kde-base/kdesdk
parentSpring Cleaning (diff)
downloadhistorical-1f0d82e30a76e7b698e006c0b23ef4ba43d716db.tar.gz
historical-1f0d82e30a76e7b698e006c0b23ef4ba43d716db.tar.bz2
historical-1f0d82e30a76e7b698e006c0b23ef4ba43d716db.zip
Spring cleaning.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/kdesdk')
-rw-r--r--kde-base/kdesdk/ChangeLog7
-rw-r--r--kde-base/kdesdk/files/umbrello-diagram-fix.diff21
-rw-r--r--kde-base/kdesdk/kdesdk-3.5.6-r1.ebuild68
-rw-r--r--kde-base/kdesdk/kdesdk-3.5.6.ebuild41
-rw-r--r--kde-base/kdesdk/kdesdk-3.5.7.ebuild70
5 files changed, 6 insertions, 201 deletions
diff --git a/kde-base/kdesdk/ChangeLog b/kde-base/kdesdk/ChangeLog
index 7b7f2ca5320a..340dab2153e4 100644
--- a/kde-base/kdesdk/ChangeLog
+++ b/kde-base/kdesdk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kdesdk
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/ChangeLog,v 1.160 2008/01/31 02:26:52 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/ChangeLog,v 1.161 2008/02/17 02:34:38 ingmar Exp $
+
+ 16 Feb 2008; Ingmar Vanhassel <ingmar@gentoo.org>
+ -files/umbrello-diagram-fix.diff, -kdesdk-3.5.6.ebuild,
+ -kdesdk-3.5.6-r1.ebuild, -kdesdk-3.5.7.ebuild:
+ Spring cleaning
31 Jan 2008; Brent Baude <ranger@gentoo.org> kdesdk-3.5.8.ebuild:
Marking kdesdk-3.5.8 ppc for bug 207634
diff --git a/kde-base/kdesdk/files/umbrello-diagram-fix.diff b/kde-base/kdesdk/files/umbrello-diagram-fix.diff
deleted file mode 100644
index 5aff562c03fd..000000000000
--- a/kde-base/kdesdk/files/umbrello-diagram-fix.diff
+++ /dev/null
@@ -1,21 +0,0 @@
-diff -ru umbrello-3.5.6.orig/umbrello/umbrello/umldoc.cpp umbrello-3.5.6/umbrello/umbrello/umldoc.cpp
---- umbrello-3.5.6.orig/umbrello/umbrello/umldoc.cpp 2007-01-15 03:24:47.000000000 -0800
-+++ umbrello-3.5.6/umbrello/umbrello/umldoc.cpp 2007-03-18 03:21:32.000000000 -0700
-@@ -147,15 +147,10 @@
- if ( pApp->getListView() )
- connect(this, SIGNAL(sigObjectRemoved(UMLObject *)), view, SLOT(slotObjectRemoved(UMLObject *)));
-
-- UMLView * previousView = pApp->getCurrentView();
- pApp->setCurrentView(view);
- if ( ! m_bLoading ) {
-- if (previousView == NULL) {
-- view -> show();
-- emit sigDiagramChanged(view ->getType());
-- } else {
-- view -> hide();
-- }
-+ view->show();
-+ emit sigDiagramChanged(view ->getType());
- }
-
- Settings::OptionState optionState = Settings::getOptionState();
diff --git a/kde-base/kdesdk/kdesdk-3.5.6-r1.ebuild b/kde-base/kdesdk/kdesdk-3.5.6-r1.ebuild
deleted file mode 100644
index 03c8c873173d..000000000000
--- a/kde-base/kdesdk/kdesdk-3.5.6-r1.ebuild
+++ /dev/null
@@ -1,68 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.5.6-r1.ebuild,v 1.3 2007/07/11 01:08:47 mr_bones_ Exp $
-
-inherit db-use kde-dist
-
-DESCRIPTION="KDE SDK: Cervisia, KBabel, KCachegrind, Kompare, Umbrello,..."
-
-SRC_URI="${SRC_URI} mirror://gentoo/kdesdk-3.5-patchset-01.tar.bz2"
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="berkdb kdehiddenvisibility subversion"
-
-DEPEND="!alpha? ( !sparc? ( !ia64? ( >=dev-util/valgrind-3.2.0 ) ) )
- subversion? ( dev-util/subversion )
- berkdb? ( =sys-libs/db-4* )"
-
-RDEPEND="${DEPEND}
- dev-util/cvs
- media-gfx/graphviz"
-
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-pkg_setup() {
- if use subversion ; then
- if [[ -n "$(svn-config --includes | grep -o /usr/include/apr-0)" ]] \
- && ! has_version =dev-libs/apr-0* ;
- then
- eerror "Subversion has been built against =dev-libs/apr-0*, but no matching version is installed."
- die "Please rebuild dev-util/subversion."
- fi
- if [[ -n "$(svn-config --includes | grep -o /usr/include/apr-1)" ]] \
- && ! has_version =dev-libs/apr-1* ;
- then
- eerror "Subversion has been built against =dev-libs/apr-1*, but no matching version is installed."
- die "Please rebuild dev-util/subversion."
- fi
- fi
-}
-
-src_compile() {
- local myconf="$(use_with subversion)"
-
- if use berkdb; then
- myconf="${myconf} --with-berkeley-db --with-db-lib="$(db_libname)"
- --with-extra-includes=$(db_includedir)"
- else
- myconf="${myconf} --without-berkeley-db"
- fi
-
- if use subversion ; then
- if [[ -n "$(svn-config --includes | grep -o /usr/include/apr-0)" ]] ; then
- myconf="--with-apr-config=/usr/bin/apr-config"
- else
- myconf="--with-apr-config=/usr/bin/apr-1-config"
- fi
- fi
-
- kde_src_compile
-}
-
-src_install() {
- kde_src_install
- for f in ${KDEDIR}/share/apps/kapptemplate/admin/{bcheck,conf.change,config,detect-autoconf}.pl ; do
- fperms 755 ${f}
- done
-}
diff --git a/kde-base/kdesdk/kdesdk-3.5.6.ebuild b/kde-base/kdesdk/kdesdk-3.5.6.ebuild
deleted file mode 100644
index 0a8b2273fa3c..000000000000
--- a/kde-base/kdesdk/kdesdk-3.5.6.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.5.6.ebuild,v 1.5 2007/04/21 14:21:56 philantrop Exp $
-
-inherit db-use kde-dist
-
-DESCRIPTION="KDE SDK: Cervisia, KBabel, KCachegrind, Kompare, Umbrello,..."
-
-KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
-IUSE="berkdb kdehiddenvisibility subversion"
-
-DEPEND="x86? ( >=dev-util/valgrind-3.2.0 )
- subversion? ( dev-util/subversion )
- berkdb? ( =sys-libs/db-4* )"
-
-RDEPEND="${DEPEND}
- dev-util/cvs
- media-gfx/graphviz"
-
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-src_unpack() {
- kde_src_unpack
-
- # Patch to fix bug 171328
- epatch ${FILESDIR}/umbrello-diagram-fix.diff
-}
-
-src_compile() {
- local myconf="$(use_with subversion)"
-
- if use berkdb; then
- myconf="${myconf} --with-berkeley-db --with-db-lib="$(db_libname)"
- --with-extra-includes=$(db_includedir)"
- else
- myconf="${myconf} --without-berkeley-db"
- fi
-
- kde_src_compile
-}
diff --git a/kde-base/kdesdk/kdesdk-3.5.7.ebuild b/kde-base/kdesdk/kdesdk-3.5.7.ebuild
deleted file mode 100644
index 81b057187362..000000000000
--- a/kde-base/kdesdk/kdesdk-3.5.7.ebuild
+++ /dev/null
@@ -1,70 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kdesdk/kdesdk-3.5.7.ebuild,v 1.8 2007/08/11 17:11:52 armin76 Exp $
-
-inherit db-use kde-dist
-
-DESCRIPTION="KDE SDK: Cervisia, KBabel, KCachegrind, Kompare, Umbrello,..."
-
-SRC_URI="${SRC_URI} mirror://gentoo/kdesdk-3.5-patchset-01.tar.bz2"
-
-KEYWORDS="alpha amd64 ia64 ppc sparc x86"
-IUSE="berkdb kdehiddenvisibility subversion"
-
-DEPEND="!alpha? ( !sparc? ( !ia64? ( >=dev-util/valgrind-3.2.0 ) ) )
- subversion? ( dev-util/subversion )
- berkdb? ( =sys-libs/db-4* )"
-
-RDEPEND="${DEPEND}
- dev-util/cvs
- media-gfx/graphviz"
-
-DEPEND="${RDEPEND}
- sys-devel/flex"
-
-pkg_setup() {
- if use subversion ; then
- if [[ -n "$(ldd /usr/bin/svn | grep -o libapr-0)" ]] \
- && ! has_version =dev-libs/apr-0* ;
- then
- eerror "Subversion has been built against =dev-libs/apr-0*, but no matching version is installed."
- die "Please rebuild dev-util/subversion."
- fi
- if [[ -n "$(ldd /usr/bin/svn | grep -o libapr-1)" ]] \
- && ! has_version =dev-libs/apr-1* ;
- then
- eerror "Subversion has been built against =dev-libs/apr-1*, but no matching version is installed."
- die "Please rebuild dev-util/subversion."
- fi
- fi
-}
-
-src_compile() {
- local myconf="$(use_with subversion)"
-
- if use berkdb; then
- myconf="${myconf} --with-berkeley-db --with-db-lib="$(db_libname)"
- --with-extra-includes=$(db_includedir)"
- else
- myconf="${myconf} --without-berkeley-db"
- fi
-
- if use subversion ; then
- if [[ -n "$(ldd /usr/bin/svn | grep -o libapr-0)" ]] ; then
- myconf="--with-apr-config=/usr/bin/apr-config
- --with-apu-config=/usr/bin/apu-config"
- else
- myconf="--with-apr-config=/usr/bin/apr-1-config
- --with-apu-config=/usr/bin/apu-1-config"
- fi
- fi
-
- kde_src_compile
-}
-
-src_install() {
- kde_src_install
- for f in ${KDEDIR}/share/apps/kapptemplate/admin/{bcheck,conf.change,config,detect-autoconf}.pl ; do
- fperms 755 ${f}
- done
-}