summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2008-11-09 02:52:26 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2008-11-09 02:52:26 +0000
commit884448fe539d8d03e15d3b454fb0413fe9b6fbbc (patch)
tree1f45a51ef736830a005781f5a511fee20d294f84 /kde-base/kontact/kontact-4.1.3.ebuild
parentFixup 4.1.3 mask, so no more empty lines. (diff)
downloadhistorical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.tar.gz
historical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.tar.bz2
historical-884448fe539d8d03e15d3b454fb0413fe9b6fbbc.zip
Full auto: Version bump for KDE-4.1.3
Package-Manager: portage-2.2_rc12/cvs/Linux 2.6.26-gentoo i686
Diffstat (limited to 'kde-base/kontact/kontact-4.1.3.ebuild')
-rw-r--r--kde-base/kontact/kontact-4.1.3.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/kde-base/kontact/kontact-4.1.3.ebuild b/kde-base/kontact/kontact-4.1.3.ebuild
new file mode 100644
index 000000000000..162ded2d2ad6
--- /dev/null
+++ b/kde-base/kontact/kontact-4.1.3.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kontact/kontact-4.1.3.ebuild,v 1.1 2008/11/09 00:59:04 scarabeus Exp $
+
+EAPI="2"
+
+KMNAME=kdepim
+inherit kde4-meta
+
+DESCRIPTION="KDE personal information manager"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug htmlhandbook"
+
+DEPEND="app-crypt/gnupg
+ app-crypt/gpgme
+ >=kde-base/kontactinterfaces-${PV}:${SLOT}
+ >=kde-base/libkdepim-${PV}:${SLOT}"
+RDEPEND="${DEPEND}"
+
+KMLOADLIBS="libkdepim"
+KMSAVELIBS="true"
+
+# We remove plugins that are related to external kdepim programs. This way
+# kontact doesn't have to depend on all programs it has plugins for.
+#
+# xml targets from kmail/ are being uncommented by kde4-meta.eclass
+KMEXTRACTONLY="libkdepim/
+ kmail/
+ kontact/plugins/akregator/
+ kontact/plugins/kaddressbook/
+ kontact/plugins/kjots/
+ kontact/plugins/kmail/
+ kontact/plugins/kmobiletools
+ kontact/plugins/knode/
+ kontact/plugins/knotes/
+ kontact/plugins/korganizer/
+ kontact/plugins/ktimetracker/
+ kontact/plugins/planner/
+ kontact/plugins/specialdates/
+ kontactinterfaces/"