summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDan Armak <danarmak@gentoo.org>2005-05-25 21:23:15 +0000
committerDan Armak <danarmak@gentoo.org>2005-05-25 21:23:15 +0000
commit61fc0b979044371777fbf1d14db2d7c3c0a9427b (patch)
tree3541ae4ee7ec45c2e901153b1a64cbe8f1fdd1c7 /kde-base/kpilot
parentAdd the missing HOMEPAGE variable so repoman doesn't complain. (diff)
downloadhistorical-61fc0b979044371777fbf1d14db2d7c3c0a9427b.tar.gz
historical-61fc0b979044371777fbf1d14db2d7c3c0a9427b.tar.bz2
historical-61fc0b979044371777fbf1d14db2d7c3c0a9427b.zip
KDE 3.4.1 ebuilds; package.masked as they aren't released yet
Package-Manager: portage-2.0.51.22-r1
Diffstat (limited to 'kde-base/kpilot')
-rw-r--r--kde-base/kpilot/ChangeLog8
-rw-r--r--kde-base/kpilot/Manifest6
-rw-r--r--kde-base/kpilot/files/digest-kpilot-3.4.12
-rw-r--r--kde-base/kpilot/kpilot-3.4.1.ebuild37
4 files changed, 50 insertions, 3 deletions
diff --git a/kde-base/kpilot/ChangeLog b/kde-base/kpilot/ChangeLog
index ce7ce0dbe152..3ac235b85aab 100644
--- a/kde-base/kpilot/ChangeLog
+++ b/kde-base/kpilot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for kde-base/kpilot
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.7 2005/03/26 01:11:06 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/ChangeLog,v 1.8 2005/05/25 21:23:10 danarmak Exp $
+
+*kpilot-3.4.1 (25 May 2005)
+
+ 25 May 2005; Dan Armak <danarmak@gentoo.org> +kpilot-3.4.1.ebuild:
+ Ebuilds for KDE 3.4.1. These are package.masked until 3.4.1 is actually
+ released. You can't get the tarballs yet.
26 Mar 2005; Jason Wever <weeve@gentoo.org> kpilot-3.4.0.ebuild:
Added ~sparc keyword.
diff --git a/kde-base/kpilot/Manifest b/kde-base/kpilot/Manifest
index 47e4871f299b..f05f57072e83 100644
--- a/kde-base/kpilot/Manifest
+++ b/kde-base/kpilot/Manifest
@@ -1,4 +1,6 @@
-MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
-MD5 3c3dd9e513907a971d1cec20d57e2297 ChangeLog 1304
MD5 e443f3f492ca9ec881787fd300705c75 kpilot-3.4.0.ebuild 1181
+MD5 7fb86c322736e6e4fc7d1688137cbecd kpilot-3.4.1.ebuild 1169
+MD5 e4a61329cc062c77adc243bf5d5b2c3b ChangeLog 1521
+MD5 acc03a4b12bb0433a57e95bd253b9501 metadata.xml 156
MD5 8c0ffea7b75b42449f4acada755ff36a files/digest-kpilot-3.4.0 67
+MD5 7e3e5fdc63982b39b9df921e916f246a files/digest-kpilot-3.4.1 134
diff --git a/kde-base/kpilot/files/digest-kpilot-3.4.1 b/kde-base/kpilot/files/digest-kpilot-3.4.1
new file mode 100644
index 000000000000..50c8351c10a7
--- /dev/null
+++ b/kde-base/kpilot/files/digest-kpilot-3.4.1
@@ -0,0 +1,2 @@
+MD5 7f8cc9a40c0190c5a6723f6325bcba06 kdepim-3.4.0.tar.bz2 11441545
+MD5 e5515aa230558bac8651e9cd9f8f9673 kdepim-3.4.1.tar.bz2 11345538
diff --git a/kde-base/kpilot/kpilot-3.4.1.ebuild b/kde-base/kpilot/kpilot-3.4.1.ebuild
new file mode 100644
index 000000000000..6b13d9a54124
--- /dev/null
+++ b/kde-base/kpilot/kpilot-3.4.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kpilot/kpilot-3.4.1.ebuild,v 1.1 2005/05/25 21:23:10 danarmak Exp $
+
+KMNAME=kdepim
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KPilot - HotSync software for KDE"
+KEYWORDS="~x86 ~amd64"
+IUSE=""
+DEPEND="app-pda/pilot-link
+ dev-libs/libmal
+$(deprange $PV $MAXKDEVER kde-base/libkcal)
+$(deprange $PV $MAXKDEVER kde-base/libkdepim)
+$(deprange $PV $MAXKDEVER kde-base/kontact)"
+
+KMCOPYLIB="
+ libkcal libkcal
+ libkdepim libkdepim
+ libkpinterfaces kontact/interfaces"
+# libkcal is installed because a lot of headers are needed, but it don't have to be compiled
+KMEXTRACTONLY="
+ libkcal/
+ libkdepim libkdepim/
+ kontact/interfaces/"
+KMEXTRA="
+ kfile-plugins/palm-databases
+ kontact/plugins/kpilot/" # We add here the kontact's plugin instead of compiling it with kontact because it needs a lot of this programs deps.
+
+src_compile() {
+ # needed to detect pi-notepad.h, used by the kpilot notepad conduit.
+ myconf="${myconf} --with-extra-includes=/usr/include/libpisock"
+
+ kde-meta_src_compile
+}