summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCarsten Lohrke <carlo@gentoo.org>2008-09-14 00:00:42 +0000
committerCarsten Lohrke <carlo@gentoo.org>2008-09-14 00:00:42 +0000
commitb974b6ef740bd72ca318243730adf05a46a3ac13 (patch)
tree83960462b16e9bb431666835e4b3d90f67f1c45c /kde-base/kscd/kscd-3.5.10.ebuild
parentVersion bump and include patch to support Audacious 1.5. (diff)
downloadhistorical-b974b6ef740bd72ca318243730adf05a46a3ac13.tar.gz
historical-b974b6ef740bd72ca318243730adf05a46a3ac13.tar.bz2
historical-b974b6ef740bd72ca318243730adf05a46a3ac13.zip
Version bump.
Diffstat (limited to 'kde-base/kscd/kscd-3.5.10.ebuild')
-rw-r--r--kde-base/kscd/kscd-3.5.10.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/kscd/kscd-3.5.10.ebuild b/kde-base/kscd/kscd-3.5.10.ebuild
new file mode 100644
index 000000000000..8c4bf201952c
--- /dev/null
+++ b/kde-base/kscd/kscd-3.5.10.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kscd/kscd-3.5.10.ebuild,v 1.1 2008/09/13 23:59:41 carlo Exp $
+
+KMNAME=kdemultimedia
+EAPI="1"
+inherit kde-meta eutils
+
+SRC_URI="${SRC_URI}"
+
+DESCRIPTION="KDE CD player"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="x11-libs/libXext
+ >=kde-base/libkcddb-${PV}:${SLOT}"
+
+KMCOPYLIB="libkcddb libkcddb"
+KMCOMPILEONLY="libkcddb"
+
+PATCHES=( "${FILESDIR}/kscd-3.5.6-alsa-tests.patch"
+ "${FILESDIR}/kscd-3.5.6-arts.patch"
+ "${FILESDIR}/kscd-3.5-strict-fix.diff" )
+
+src_compile() {
+ DO_NOT_COMPILE=libkcddb kde-meta_src_compile myconf configure
+ cd "$S"/libkcddb && emake configbase.h
+ cd "$S"/libkcddb && emake cdinfodialogbase.h
+ DO_NOT_COMPILE=libkcddb kde-meta_src_compile make
+}