summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 18:25:49 +0000
committerAlexey Shvetsov <alexxy@gentoo.org>2009-01-27 18:25:49 +0000
commit4b56a9456112f0424b9de968daac0612d94c4386 (patch)
treee49905f06cc5d2008a7b44b78bdb1d963298c15d /kde-base/kwin/kwin-4.2.0.ebuild
parentcleanout (diff)
downloadhistorical-4b56a9456112f0424b9de968daac0612d94c4386.tar.gz
historical-4b56a9456112f0424b9de968daac0612d94c4386.tar.bz2
historical-4b56a9456112f0424b9de968daac0612d94c4386.zip
Bump shiny new KDE 4.2.0
Package-Manager: portage-2.2_rc23/cvs/Linux x86_64
Diffstat (limited to 'kde-base/kwin/kwin-4.2.0.ebuild')
-rw-r--r--kde-base/kwin/kwin-4.2.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/kde-base/kwin/kwin-4.2.0.ebuild b/kde-base/kwin/kwin-4.2.0.ebuild
new file mode 100644
index 000000000000..b4f8e87f16f8
--- /dev/null
+++ b/kde-base/kwin/kwin-4.2.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.2.0.ebuild,v 1.1 2009/01/27 18:04:59 alexxy Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug captury xcomposite xinerama"
+
+COMMONDEPEND="x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ captury? ( media-libs/libcaptury )
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ kde-base/kephal:${SLOT}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+src_configure() {
+ if ! use captury; then
+ sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+ -i "${S}"/kwin/effects/CMakeLists.txt || \
+ die "Making captury optional failed."
+ fi
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}