summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-11-02 22:15:40 +0000
committerAlex Alexander <wired@gentoo.org>2009-11-02 22:15:40 +0000
commit2949ed61ac331b42c84eab992aba8a8aa245811c (patch)
treeb8dc20afdeb0bb71b28d488e020b2d45cf5f25a6 /kde-base/kwin
parentRemoving 0.1.0 ebuild (diff)
downloadhistorical-2949ed61ac331b42c84eab992aba8a8aa245811c.tar.gz
historical-2949ed61ac331b42c84eab992aba8a8aa245811c.tar.bz2
historical-2949ed61ac331b42c84eab992aba8a8aa245811c.zip
Version bump KDE 4.3.3
Package-Manager: portage-2.2_rc48/cvs/Linux x86_64 RepoMan-Options: --force
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.3.3.ebuild57
2 files changed, 63 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 1176b637ddf4..b18f74192ca0 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.167 2009/10/18 15:59:10 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.168 2009/11/02 21:54:42 wired Exp $
+
+*kwin-4.3.3 (02 Nov 2009)
+
+ 02 Nov 2009; Alex Alexander <wired@gentoo.org> +kwin-4.3.3.ebuild:
+ Version bump
18 Oct 2009; Markus Meier <maekke@gentoo.org> kwin-4.3.1.ebuild:
x86 stable, bug #287697
diff --git a/kde-base/kwin/kwin-4.3.3.ebuild b/kde-base/kwin/kwin-4.3.3.ebuild
new file mode 100644
index 000000000000..75f89852efcc
--- /dev/null
+++ b/kde-base/kwin/kwin-4.3.3.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.3.3.ebuild,v 1.1 2009/11/02 21:54:42 wired Exp $
+
+EAPI="2"
+
+KMNAME="kdebase-workspace"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="debug xcomposite xinerama"
+
+# NOTE disabled for now: captury? ( media-libs/libcaptury )
+COMMONDEPEND="
+ $(add_kdebase_dep kephal)
+ $(add_kdebase_dep libkworkspace)
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )
+"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )
+"
+RDEPEND="${COMMONDEPEND}"
+
+src_prepare() {
+# NOTE uncomment when enabled again by upstream
+# if ! use captury; then
+# sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+# -i kwin/effects/CMakeLists.txt || \
+# die "Making captury optional failed."
+# fi
+ # Dirty hax to fix building without OpenGL
+ if ! use opengl; then
+ sed -e 's|^[[:space:]]*windowOpacity.*|// commented out &|' \
+ -i kwin/effects/logout/logout.cpp || \
+ die "Commenting out windowOpacity failed."
+ fi
+
+ kde4-meta_src_prepare
+}
+
+src_configure() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)"
+
+ kde4-meta_src_configure
+}