summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIngmar Vanhassel <ingmar@gentoo.org>2008-05-16 00:40:39 +0000
committerIngmar Vanhassel <ingmar@gentoo.org>2008-05-16 00:40:39 +0000
commit9a67d2a7181071ed64a23a56c06b3ae89a00907e (patch)
tree4f5c62961e37a16ee3727c1fc80e2228f869dd91 /kde-base/kwin
parentAdded KDE 4.0.4 version of kweather. Thanks to Jorge Manuel B. S. Vicetto. (diff)
downloadhistorical-9a67d2a7181071ed64a23a56c06b3ae89a00907e.tar.gz
historical-9a67d2a7181071ed64a23a56c06b3ae89a00907e.tar.bz2
historical-9a67d2a7181071ed64a23a56c06b3ae89a00907e.zip
Added KDE 4.0.4 version of kwin. Thanks to Jorge Manuel B. S. Vicetto.
Package-Manager: portage-2.1.5
Diffstat (limited to 'kde-base/kwin')
-rw-r--r--kde-base/kwin/ChangeLog7
-rw-r--r--kde-base/kwin/kwin-4.0.4.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/kde-base/kwin/ChangeLog b/kde-base/kwin/ChangeLog
index 0aed551a3878..a78e33acdd18 100644
--- a/kde-base/kwin/ChangeLog
+++ b/kde-base/kwin/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for kde-base/kwin
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.124 2008/05/15 13:03:24 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/ChangeLog,v 1.125 2008/05/16 00:40:39 ingmar Exp $
+
+*kwin-4.0.4 (15 May 2008)
+
+ 15 May 2008; Ingmar Vanhassel <ingmar@gentoo.org> +kwin-4.0.4.ebuild:
+ Added KDE 4.0.4 version of kwin. Thanks to Jorge Manuel B. S. Vicetto.
15 May 2008; Markus Rothe <corsair@gentoo.org> kwin-3.5.9-r1.ebuild:
Stable on ppc64; bug #221063
diff --git a/kde-base/kwin/kwin-4.0.4.ebuild b/kde-base/kwin/kwin-4.0.4.ebuild
new file mode 100644
index 000000000000..92307add71f6
--- /dev/null
+++ b/kde-base/kwin/kwin-4.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-4.0.4.ebuild,v 1.1 2008/05/16 00:40:39 ingmar Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~amd64 ~x86"
+IUSE="captury debug opengl xcomposite xinerama"
+
+COMMONDEPEND="
+ x11-libs/libXdamage
+ x11-libs/libXfixes
+ >=x11-libs/libXrandr-1.2.1
+ x11-libs/libXrender
+ captury? ( media-libs/libcaptury )
+ opengl? ( virtual/opengl )
+ xcomposite? ( x11-libs/libXcomposite )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ x11-proto/damageproto
+ x11-proto/renderproto
+ xcomposite? ( x11-proto/compositeproto )
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+src_compile() {
+ if ! use captury; then
+ sed -e 's:^PKGCONFIG..libcaptury:#DONOTFIND &:' \
+ -i "${S}"/kwin/effects/CMakeLists.txt || \
+ die "Making captury optional failed."
+ fi
+
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xcomposite X11_Xcomposite)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}