summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
committerWulf Krueger <philantrop@gentoo.org>2008-04-03 21:49:41 +0000
commitc720f79a21ec6fc47b92109987daca264d416bff (patch)
tree1b6bd65f854b288e82f20100a5ed85c008e3511e /kde-base/libplasma
parentadded ~amd64 (diff)
downloadhistorical-c720f79a21ec6fc47b92109987daca264d416bff.tar.gz
historical-c720f79a21ec6fc47b92109987daca264d416bff.tar.bz2
historical-c720f79a21ec6fc47b92109987daca264d416bff.zip
Version bump to KDE 4.0.3. This is still not intended for mainstream so DO NOT KEYWORD IT without talking to the KDE herd first.
Package-Manager: portage-2.1.4.4
Diffstat (limited to 'kde-base/libplasma')
-rw-r--r--kde-base/libplasma/ChangeLog9
-rw-r--r--kde-base/libplasma/libplasma-4.0.3.ebuild54
2 files changed, 62 insertions, 1 deletions
diff --git a/kde-base/libplasma/ChangeLog b/kde-base/libplasma/ChangeLog
index 7401b9046576..27c5728e9b38 100644
--- a/kde-base/libplasma/ChangeLog
+++ b/kde-base/libplasma/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for kde-base/libplasma
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/ChangeLog,v 1.5 2008/03/20 18:18:51 ingmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/ChangeLog,v 1.6 2008/04/03 21:42:53 philantrop Exp $
+
+*libplasma-4.0.3 (03 Apr 2008)
+
+ 03 Apr 2008; Wulf C. Krueger <philantrop@gentoo.org>
+ +libplasma-4.0.3.ebuild:
+ Version bump to KDE 4.0.3. This is still not intended for mainstream so DO
+ NOT KEYWORD IT without talking to the KDE herd first.
20 Mar 2008; Ingmar Vanhassel <ingmar@gentoo.org> -libplasma-4.0.1.ebuild:
Old.
diff --git a/kde-base/libplasma/libplasma-4.0.3.ebuild b/kde-base/libplasma/libplasma-4.0.3.ebuild
new file mode 100644
index 000000000000..80770bdbeac9
--- /dev/null
+++ b/kde-base/libplasma/libplasma-4.0.3.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/libplasma/libplasma-4.0.3.ebuild,v 1.1 2008/04/03 21:42:53 philantrop Exp $
+
+EAPI="1"
+
+KMNAME=kdebase-workspace
+KMMODULE="libs/plasma"
+CPPUNIT_REQUIRED="optional"
+OPENGL_REQUIRED="optional"
+inherit kde4-meta
+
+DESCRIPTION="Plasma: KDE desktop framework"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug opengl test xinerama"
+
+COMMONDEPEND="
+ !<kde-base/plasma-3.96.0
+ >=kde-base/libkworkspace-${PV}:${SLOT}
+ >=kde-base/libtaskmanager-${PV}:${SLOT}
+ x11-libs/libXau
+ x11-libs/libXfixes
+ x11-libs/libXrender
+ x11-libs/libXtst
+ opengl? ( virtual/opengl )
+ xinerama? ( x11-libs/libXinerama )"
+DEPEND="${COMMONDEPEND}
+ xinerama? ( x11-proto/xineramaproto )"
+RDEPEND="${COMMONDEPEND}"
+
+KMEXTRACTONLY="krunner/org.freedesktop.ScreenSaver.xml
+ krunner/org.kde.krunner.Interface.xml
+ ksmserver/org.kde.KSMServerInterface.xml
+ libs/taskmanager/"
+
+KDE4_BUILT_WITH_USE_CHECK="app-misc/strigi dbus qt4"
+
+# Disabling tests for now. 3 out of 3 broken now. last tested on 4.0.1.
+RESTRICT="test"
+
+src_compile() {
+ mycmakeargs="${mycmakeargs}
+ $(cmake-utils_use_with opengl OpenGL)
+ $(cmake-utils_use_with xinerama X11_Xinerama)"
+
+ kde4-meta_src_compile
+}
+
+src_install() {
+ kde4-meta_src_install
+
+ # Outsmart our doc-handling, to avoid a collision with plasma.
+ rm -rf "${D}"/${KDEDIR}/share/doc/
+}